System installation problem on IRB 6400R M99 S4C


After a fault has happened in the power supply, it has been fixed, now the memory is empty and required new system installation.

So when I tried to install Robware 3.2 V56, it performs all the tests and asks for the key disk, I do insert the key disk and press a key, it's obvious it's trying to read from the floppy drive (which is fully functional) but it does not proceed, it keeps asking for the key disk. I wonder if this is related to a hardware issue like the Back Plane or Panel board? or it's related to the software, but I got the files from the company I bought the robot from.

I would highly appreciate your help and advice.

Best regards,


  • graemepaulingraemepaulin New Zealand ✭✭✭

    As you are getting past the tests without error it is probably the floppy disk or the drive.

    Can you read the key disk in another floppy drive (portable usb type maybe), to check if the disk is readable?

  • yazanyazan Sweden
    Hi Graemepaulin,

    Thank you for your reply, actually the floppy drive itself works fine, i also tried a usb floppy drive emulator, which also works fine, I'm trying to specify where the problem is, could it be the back plane or the panel unit (which has its Enable led off, is it normal since it has no software installed? )

    I do need your help, the boards (robot computer, memory and main computer) have been tested and they work fine.

    Looking forward for your reply,

    Best regards,
  • graemepaulingraemepaulin New Zealand ✭✭✭
    Are you able to read the disk on normal PC to ensure the disk is readable?
  • yazanyazan Sweden
    Yes I have tested it on a PC, and I also tried a usb, same result. 
  • graemepaulingraemepaulin New Zealand ✭✭✭

    When you same result  do you mean you could not read the disk using a PC

  • yazanyazan Sweden
    No, I mean using the floppy drive (with floppy disk) and the usb floppy emulator (with usb stick) gives the same results ==> it tries to read but keeps askig for the key disk, I'm sure the drive and the disk and the usb are working fine, I tried them on a PC, and I used a different tested floppy drive.
  • graemepaulingraemepaulin New Zealand ✭✭✭

    My experience has been that if the self  check test passes there is nothing wrong with your hardware.

    Open the key disk on a PC and check that the serial number matches that of the controller.

  • SkooterSkooter Michigan

    I've seen directories incorrectly copied to the key disk.  Make sure the key disk has only these 3 files in the root directory:


Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!