Brakes will not release

Good morning,
  I am working with IRB4400/S4c. I have been attempting to work thru an issue involving brakes not releasing. I can verify 24v to ground at each motor for brakes. No reading from 0v to 24+. Push buttons do not respond although there is 24v at the buttons.


  • Are there any additional messages in the event log? When you activate the pushbutton, is it just one of the brakes or both? 
  • I am unable to get any of the brakes to respond at the push buttons. When using the teach pendant, however, I get the tell-tale click, but the axis does not move, and a joint collision is generated.
  • graemepaulin
    graemepaulin New Zealand mod
    You should only have 24 VDC at the brakes when the brake contactor is pulled in (manual mode you have to move the joy stick to get the brake contactor to operate). or when you operate the brake release button.

    It sounds like you may have a broken core in the cabling up the robot.
  • I can verify that the 24v supply does drop after releasing the joystick. I am also able to verify the 24v supply drop on the “load” side of the pushbuttons. 
      I have fluctuating voltage readings for supply power to the axis motors as well. Using a fluke T-5 (which is auto-ranging) I have measured voltage from 205VAC to 260VAC when cycling k1 and k2 contractors. What is more curious is that the meter will read 185VDC at the same time, swapping back and forth between AC and DC. I can understand some DC ripple, but it sometimes remains constant. Quite confused.
  •  :/ *contactors*
  • graemepaulin
    graemepaulin New Zealand mod
    By load side you mean the motor side of the brake push buttons?
    The 24 VDC to the buttons should be present at all times when the controller is powered up (ie it does not go via the brake contactor), so you should get 24 VDC on the motor side of the button when you press it (measured at the button).
    If that is correct then there must be a cable break from there up the robot.
  • I can measure 24v at the brake, (axis 3) and it holds until I get a joint collision error, actual torque on joint is higher than ordered, or position further away etc...
  • I can move axis 2 slowly, axis 1 seems to force thru the brake, axis 3 I cannot move at all. I can move 4, 5. 6 I cannot move at all. I suppose this has a lot to do with gear reduction. Very frustrating
  • I connected a different axis motor, with the same result. 24v to the motor brake, but still no brake release.
  • After finding 0v wire not fully landed in terminal, I have some movement, and release of the brakes. Now any axis commanded only 2 or 3 attempts to move. And results in collision detect, or speed fault on axis 3.
  • graemepaulin
    graemepaulin New Zealand mod
    To clarify you now have all brakes releasing?
    Multiple axis not working sounds like power to brake system or main power to controller/drive unit - but the controller should report errors if there was under voltage.... 

    With manual release of the brake you should be able to move axis 1, 4, 5, 6 one at a time by hand (2 and 3 will drop on a large robot like the IRB4400 so not safe to try a manual movement of those two).

    If there is still any doubt about the brakes get a known good 24 VDC bench power supply and connect it directly to the brake at the motor power plug - again axis 2 and 3 will drop so unless you can support these axis safely do not release their brakes.
    I would have the controller power off (and locked out), also the robot power plug at the base of the robot unplugged to isolate the controller completely....
    This will eliminate the robot wiring, power supply in the controller, etc - if above test (moving axis by hand with external power supply connect directly to brake at the motor) shows the brake is now operating correctly then move the power supply down to the brake pins in the power connection plug on the base of the robot.

    Needless to say caution is required to connect to the correct pins in the plugs and not short out to any neighboring pins.