SmartGripper calibration in RobotStudio

IzaRIzaR Poland
edited March 2017 in YuMi

Hi,

does anyone know how to calibrate SmartGripper in RobotStudio? I have program in Virtual Contrroler and program stops when I want to Calibrate SmartGripper. In the other hand if I comment this line then the error appears: Hand not calibrated.

I would be grateful if you will help me.



Comments

  • davidshanerdavidshaner Newbury, OH
    This is the code I'm using for an actual YuMi controller, it might work with a virtual controller. I did have an error handling issue with initializing v3.51 that seemed to be solved with v3.52 so I'd recommend that version if you're not using it already. This won't work with versions prior to v3.51 since those use the "Hand_" notation and not the "g_" notation.
    (sorry about the formatting, this forum appears to mangle the code in my browser)
    PROC Init()
      !Initialization code
      VAR num GripperState; VAR bool GripperCalibrated; !Check gripper is powered on and calibrated. GripperState:=g_GetState(); TPWrite ": Gripper State: "\Num:=GripperState; GripperCalibrated:=g_IsCalibrated(); IF (Not GripperCalibrated) THEN g_Init\Calibrate;  ENDIF
      RETURN ; ERROR IF (ERRNO=ERR_NORUNUNIT) THEN    TPWrite " Gripper not powered on."; EXIT; ENDIF TPWrite " Init. - Unhandled Error. #"\Num:=ERRNO; EXIT;ENDPROC
  • KOSKOS NZ
    Hi, did you ever resolve this issue? I have the same problem and the above suggestion does not work for me.
    I have tried versions: 6.05 and 6.05.02 for RobotWare and version 3.40 and 3.52 for SmartGripper. Using both versions of the command prefixes 'Hand_' and 'g_'

    I get these 2 errors:
    112755 - Hand not calibrated
    40229 - Execution error

    Log is not helpful and suggests the obvious: 
    Description
    Hand_L is not calibrated

    Actions
    Calibrate the Hand

    How do I calibrate the hand? I have tried using various calibration commands (like the above suggestion) but this does not fix the issue. I suspect that perhaps the system is not setup correctly or that I am using the wrong versions but I can not find the right documentation to guide me. 

    If you know the solution or know where I can get the documentation for this then please let me know.
  • graemepaulingraemepaulin New Zealand ✭✭✭
    Try using the virtual FlexPendant to calibrate the gripper.
  • I am not able to as the calibrate button is grayed out. Any ideas why this may be?
Sign In or Register to comment.