Error in automatic program checking

CruxCrux Italy
edited March 2017 in Robot Controller
I'm facing a problem, I used sockets in other applications and this very same function worked without any issue;
is it possibly a Robotstudio bug ?
are system functions dependant on the controller used or are they universal for any controller able to use rapid?
(this is because the first time I used an irb140 and I had no problems, this time I'm using an irb120 and I got this error)

I suppose this as a robot studio bug since inside the IDE the function is correctly recognized, it is in light blue and with mouse hovering it displays the correct infos

Any idea how to solve it?


Tagged:

Comments

  • Knud E LindbergKnud E Lindberg Denmark ✭✭
    Do you have the option PC interface on the robot ?
    Regards
    Knud Erik Lindberg
    ABB Denmark
  • CruxCrux Italy
    edited March 2017
    Oh, it was easy like that, I enabled the option and it worked fine.
    I would suggest to include this info in the error log, I did not know that this option was required, I did think that pc-interface was the option for enabling the service port and that the network port was always accessible even without service port enabled; my bad.
    Thank you knud.
Sign In or Register to comment.