How to use the tool in EGM's Base Frame mode?

kazoo
kazoo San Francisco
Have anyone tried to use the tool in Base Frame mode (not in Tool Frame mode) while using Externally Guided Motion (EGM)?

I’m trying to use Base Frame mode of EGM on IRB120 and having “Dynamic load too high” error. The robot tried to go up (+z) for a very short time (less than 1sec or 0.5msec) and stopped with the error.

What I tried was just to send the current position (translation position = 400, 0, 125, rotation = 0, 1, 0, 0) as a destination. The followings are a snippet of RAPID code I used. If you notice any mistakes, please let me know. When I used Tool Frame mode with the tool or Base Frame mode without the tool, they worked as expected. 



TASK PERS tooldata myTool:=[TRUE,[[0,0,275],[1,0,0,0]],[1.0,[0,0,60],[1,0,0,0],0,0,0]];

MoveJ p1, v100, fine, myTool;

EGMActPose egmID1\Tool:= myTool, corr_frame_offs, EGM_FRAME_WORLD, myTool.tframe, EGM_FRAME_BASE \x:=egm_minmax_lin1 \y:=egm_minmax_lin1 \z:=egm_minmax_lin1 \rx:=egm_minmax_rot1 \ry:=egm_minmax_rot1 \rz:=egm_minmax_rot1 \LpFilter:=4, \MaxPosDeviation:=1000 \MaxSpeedDeviation:=1000; 

EGMRunPose egmID1, EGM_STOP_HOLD \x \y \z \Rx \Ry \Rz \CondTime:=300 \RampInTime:=0.05 \PosCorrGain:=1.0;

Comments

  • fatony
    fatony Wisconsin
    Did you do the pay load ? Sounds like the weight that you have for that tool is wrong . Your mass might be off 
  • kazoo
    kazoo San Francisco
    Thanks. I tried to set the one but didn't work well. I might make some mistakes. Could you explain more or provide sample code for this?
  • fatony
    fatony Wisconsin
    Did change your mass? When you created the tool?
  • kazoo
    kazoo San Francisco
    As described above, I created the tool like this.

    TASK PERS tooldata myTool:=[TRUE,[[0,0,275],[1,0,0,0]],[1.0,[0,0,60],[1,0,0,0],0,0,0]];


Sign In or Register to comment.