RobotStudio event

Installing and using BullsEye, Torch cleaner...

edited October 2017 in Robot Controller

My company bought an IRB 1400 which has a S4C controller. It has a BullsEye, a TorchCleaner, and other thing (I have seen some videos and I think that it is for a spray to keep the torch cleaned after finishing a welding process)
I have been using the torch cleaning by moving the torch to the cleaning spot and activating digital outputs manually (Outputs called PIB_[A number]).
I am not able to find the way to use the BullsEye, here is the guide: ( ), in the page 16 it says that there's a system module called BullsEye (I can't find it in my controller), I have tried to reinstall the OS multiple times but there is nothing referred to BullsEye during the installation, the closest thing I have found was "Positioner" but I think that It is not referred to BullsEye, It refers to ABB welding positioners.
There is another thing which has a pipe that is not connected and I don't know what is this for (Said previously that I think that is for connecting a spray).

Here is a photo of the device that I am talking about.

If it were possible could anybody tell me how to use these 3 devices with default system routines. If it's not possible, how can I make my own routine to use BullsEye (I have used the other 2 devices manually by activating outputs)

Thanks and sorry if my english it's not smooth enought, I tried to explain it the best I could. 


  • You are correct the item marked as don't know is the anti-spatter spray.

    There is a bottle of anti spatter liquid that screws onto the casting where the hose is.

    If the Torch Service Center (TSC) was part of the system originally then your system should include the option in the key string?

    I am not sure if ArcWare and the TSC came as separate option discs?

  • sch
    edited October 2017
    I have 13 discs:

    10 system pack 3.2 discs 
    System key 3.2
    RTT ware 3.2 (for the track that I didnt mention we had)
    System ware Arcitec

    During the ArcWare and Arcitec installation I can choose the following options:
    Op. Panel
    WeldGuide support and SmarTac (Which I can't choose for lack of Inputs and Outputs and produce fails)
    Torch Cleaner 

    The question is, Is BullsEye installation  inside the torch cleaner option? in that case, where is the default routine or any other thing to proceed to use the BullsEye, maybe one of those outputs (PIB_[number]) is for the BullsEye

    I have seen that at the left of the photo there's a device which seems to be a wire cutter, am I correct? I have not marked it.

    Thanks for your answer, I will take a look to the anti-spatter spray

    Post edited by sch on
  • Bullseye is part of the Torch Service Center (TSC), the Torch Cleaner is the other half of the TSC - the are available as separate items.

    So it would appear that you need the BullsEye disk - not sure if the attached will help.

  • sch
    edited October 2017
    Thanks a lot!

    Okay I tried to load the module BullsEye.sys and it says pInitial is not declared, so I created a point and called it pInitial, and now it says that pInitial has to be a matrix, Then I have tried to modify the point and looked for some way to turn it into a matrix, I found nothing. What can I do?  Does the matrix "pInitial" has to be placed on the BullsEye?, I mean, the coordinates have to move the arm there?

    Wait, ill try to load the module tcpdata to see if it solves my error

    I loaded it again and it seems to be good, no errors now and Ill try to see if it works

  • sch
    edited October 2017
    Im now stuck on the window that says:

    Program Waiting for Data!
    Robot needs to be at a point where the
    gun is positioned straight up and down
    with the gas cup breaking the beam.
    STOP, Jog robot manually, start again
    LAST, Moves to last Setup position
    Make a selection please
                                                 STOP             LAST

    If I press stop, I move the robot manually to the BullsEye and then I press Start it says
    Program Waiting for Data!
    The system has detected that the beam
    is not broken
    Program will move to previous screen

    And then goes again the to the previous window where I can press Stop or Last.

    If I press Last it says that the robot is going to start moving and If I want to proceed, If I press proceed the robot moves producing a collision with the bullseye because it choose by default Tool_0 as tcp, and if I change it to my own tcp or to tWeldGun it changes it again choosing Tool_0.

    (I tried to move the arm out of the bullseye and press proceed to see where it goes if there is nothing to collision, and if I don't stop the arm it keeps moving down almost touching the floor)

    How can I proceed in this situation
    Post edited by sch on
  • Check that the input the Bullseye is wired into turns off/on when you pass your hand through the beam.

    Page 9 of the manual says the sensor input should be wired into X4 -1 of the I/O unit.

  • graemepaulin
    edited October 2017

    The IRC5 BullsEye manual says the sensor signal is called diBE_SENSE1 not sure if it is the same in this earlier version.

    Also a slightly later revision of the manual for BullsEye7 says "When the BullsEye® is correctly wired, the sensor light and input on the I/O in the robot control cabinet should be illuminated only when the light beam of the BullsEye® is broken."

  • sch
    edited October 2017
    Okay ill check it thanks

    Edited: the name in my controller of the bullseye input which detect the torch when it moves to the bullseye turning on and off the light is  "diPIB_4_7" of the AW_Board so I can try 2 things, change the name of that input into diBE_SENSE1 or, in the files that you gave me somewhere it has to be the name diBE_SENSE1 and change it to diPIB_4_7

    Bullseye.sys is encrypted so I can't change it there, so Ill have to try to rename my input

    I renamed my input and (after turning off and on my controller) tried to execute setupbullseye routine with the torch on the bullseye, the light (which detect if the torch is on the beam) turned off and after pressing proceed the arm  moved producing a collision again. I tried to move the arm outside of the bullseye but letting it close to it so when I press proceed the light will be on, the arm will move to the bullseye turning off the light, I did, but it keeps moving producing the collision again...
    Post edited by sch on
  • If I understand what you are saying the input is off when the bream is broken?

    If so from what I posted above from the manual the input needs to be inverted so it is on when the beam is broken.

  • sch
    edited October 2017
    There's a light in the bullseye. When I pass my hand between the bullseye the sensor detects it and turn off the light, and in my teach pendant the input diPIB_4_7 now renamed to diBE_SENSE1 change its value from 0 to 1, If move my hand outside of the bullseye the light turn on and the value of the input change from 1 to 0.

    So If I understand you are saying that the light has to turn on when I pass my hand between the bullseye, or the value of the signal has to be 0 when I pass my hand and 1 when there is  nothing

    I apologize but what I understand from "Beam is broken" is that beam is not working, maybe what you mean with "Beam is broken" is "Torch is on the bullseye"?
    Ah what means "beam is broken"  is that the torch is between the red light of the photoelectric sensor

    The input value is 1 when the beam is broken, that is what you were asking me, sorry.

    I have tried to move the arm manually to the bullseye breaking the beam and it keeps giving the window that says that the beam is not broken which mean that the signal used on setupbullseye routine is not the same that which I renamed to diBE_SENSE1 (the signal that is changing value from 0 to 1 when I place the torch on the bullseye)
    Post edited by sch on
  • OK it sounds like the input is working correctly.

    Is the robot colliding with the Bullseye  - is it moving towards the side of the U instead of through it?

    If hitting the U then turn the Bullseye so the motion is through the U - the software is looking for the signal to change.

  • sch
    edited October 2017
    I posted 2 photos to show that the value of the input changes and a video asnwering what I think you are asking me for.
    If I dont stop the robot it would have collided again
    It should not say that the beam is not broken after pressing STOP when the torch is breaking it
  • sch
    edited October 2017
    I found this but it stills does not help
    Like I said first and default name was diPIB_4_7

    and this is mine 

  • I have found out that the signal should be named Sen1 - please change the signal name and try again.
  • sch
    edited October 2017
    Okay, ill do it, I had a signal named sen1 but it was the start of the operator panel

    Will feedback now with results...

    IT WORKS!! WOW!!  :#

    I will try to calibrate my TCP now and will communicate it if I have any problem

    Thanks a lot! I am really grateful!

    Okay, the robot calculated the first tcp succesfully but when it tried to calculate the second tcp accurately it gaves me error unfortunately  :'(

    I tried again and gave me error when it was going to start the second proccess of measure the tcp accurately, It was doing the same movements that it did 1 minute before but gave me error. I mean, it measured the tcp aproximately, then it started to measure accurately and after a minute it started doing the same movements of the accurately measure and gave me error
    Post edited by sch on
  • I had to stop the video in the accurately measure process and start recording again becasue the video quality was bad
  • Do you have any wire protruding from the end of the torch?

    This is needed by the program.

  • I have same problem,I will try to fix it