Unknown Error - Sync with VC

I've been getting an "Unknown Error - Synchronize with Virtual Controller" and an "Unknown Error - Move Along Path" if I try to sync to the VC or move along the path in RobotStudio 5.07.01. I think that the problem might be similar to this topic. RS has worked on this computer before, maybe last year sometime, but it hasn't worked for me.

Thanks for your help

Comments

  • Hi Kirk,

    If you double-click on the error message you should get some additional information. Post that here and we'll take a look at it.

    regards,
    Johannes

    Johannes Weiman
    Software Engineer
    ABB Robotics
  • RobotStudio .NET exception dump
    ===============================
    Base exception:
    SYS_CTRL_E_UAS_REJECT: The operation was not allowed for the given user.
    ERROR: .
    apid.c[6443]: org_code: -757 new_code: 0xc0048415; RobRapidTaskImpl.cpp[891];
       at RobApiWrapper.RobRapidTask.LoadModule(UInt32 cId, String filePath, RobRapidLoadMode loadMode)
       at ABB.Internal.RobotStudio.LgRapid.LgControllerHelper.EnsureMo dule(UInt32 clientId, String systemId, String taskName, String moduleName, RobSymbol& symConflictModule, Boolean& moduleCreated)
       at ABB.Internal.RobotStudio.LgRapid.LgControllerHelper.EnsureTe mporaryProcedure(UInt32 clientId, String systemId, String taskName, String& moduleBaseName, String& procedureBaseName)
       at ABB.Internal.RobotStudio.API.HlpMotionFunctions.MoveAlongPat h(RsPathProcedure sourcePathProcedure)
       at ABB.Robotics.RobotStudio.Stations.RsPathProcedure.MoveAlong( )
       at ABBInternal.Controller.MoveMechanismCommands.MoveAlongPath_E xecuteCommand(Object sender, ExecuteCommandEventArgs e)
       at ABB.Robotics.RobotStudio.Environment.CommandBarButton.RaiseE xecuteCommand()


  • There seems to a problem with user privileges in the virtual controller.
    Start RobotStudio Online and open the UAS Administration Tool. Check that "Default User" belongs to all groups and that the "Administrator" group has full access.

    Johannes Weiman
    Software Engineer
    ABB Robotics
  • I'm using robot studio, not robot studio online... But I did open up RS online, and couldn't open the UAS Admin tool, it was blanked out. (I did have another controller open, not the one I was using in RS though)
  • RussD
    RussD United States
    You must have write access to a controller before you can run UAS Admin against that controller.
    Russell Drown
  • For some reason it has the controller named (not the system name) by the person who used to use this computer (all the controllers are) and it logs in as her. Why is that, shouldn't it log into the controller as me, since we're in my account. Is there a way to set it up so that the controller is named, logged in, and all access is granted to me?
  • Under Output in Robot Studio Online, it says THEOTHERPERSONSUSERNAME:Write Access Available

    Doesn't that mean that I should have write access anyway?

  • AndersJ
    AndersJ Sweden mod

    Hi Kirk,

    You can reset the UAS settings by doing as follows:


    1. Shut down your VC
    ( 2. Open windows explorer and click Tools < Folder options < View < Check the checkbox "Show hidden files and folders" (if you don't already have it checked...), Then click OK.)
    3. Browse to C:Documents and SettingsAll UsersApplication DataABB Industrial ITRobotics ITRobVC
    4. Create a new temporary folder and move the filesuas_groups_template.xml, uas_groups.xml  and uas_users.xml  to this folder.
    5. Restart your system
    => A new template file will automatically be created when starting your system and the user grants will be reset to default.
    Hopefully this will solve your problems.
    Best Regards,
    __________________
    Anders Jahnberg 
    ABB Automation Technologies 
    Best regards,
    Anders Jahnberg
    ABB Robotics
  • Thanks Anders, it's working now