RS 6.07 Stop simulation freezes RAPID and Controller Tabs

ErikHagmanErikHagman Göteborg Sweden
When i stop simulation, nearly every time the tree with controllers on the left hand side of the screen freezes and i can no longer scroll or open a RAPID module. Only solution is to close and restart Robotstudio.

Comments

  • DenisFRDenisFR FRANCE ✭✭

    ...

    Hello,
    Do you use special SmartComponent?
    Have you got something in Output frame or all RS hangs?
    Have you got same in RS 6.06?
  • ErikHagmanErikHagman Göteborg Sweden
    I don't have any smart components
    It is just the tree in RAPID and Controller tab that freezes, and the ability to edit and scroll in the code. No Output from RS.
    Haven't seen it in RS 6.06

    Think it's because i have placed simulation play button  and stop button in "quick access toolbar" in the top off the window.
  • DenisFRDenisFR FRANCE ✭✭

    ...

    I cannot reproduce it...
  • FrediFredi Helsinki
    Hello ErikHogman,

    Did you find a solution to your problem?

    I am also having the same issue with RS 6.07. When I stop a simulation, the left pane browser totally freezes and the rapid window also freezes. I can switch between windows, but cant do anything within these frozen sections. Only RS shutdown and restart helps, very frustra I can run the same simulation in RS 6.05 and RS 6.06 with no issues. 

    Additionally, I have noticed also that in RS 6.07, it takes a very long time for simulation to start running. 

    Hope you can replicate this problem and recommend a solution. 
  • DenisFRDenisFR FRANCE ✭✭
    Hello,
    Can you make a step by step instructions from new solution to produce this bug?
  • THODTHOD Boise, ID
    I am having the exact same problem.  I have started to try and hit the pause button before I hit the stop button and it seems to help??  
  • THODTHOD Boise, ID
    I have been working on this, trying to get a sequence and it is because of stopping the simulation.  If I pause the simulation and then stop it, the GUI never freezes.  However, if I stop the simulation it will freeze every 2-3 times.  I am using a very large assembly, it has 3 robots and 3 tracks.


  • ErikHagmanErikHagman Göteborg Sweden
    Sorry for late answer.

    I think i had the problem because i used "As fast as possible" check box in Simulation Clock under option. 
  • THODTHOD Boise, ID
    That might make sense.  I will try that.  I was using "as fast as possible" as well.
  • THODTHOD Boise, ID
    That is it.  I am running another simulation as fast as possible and it will hang the Rapid and controller tabs.
Sign In or Register to comment.