Connecting ABB IRB 6700 RW 6.06 to AB through DSQC350

Hi

We change old IRB 6400 with S4 to new IRB 6700 RW 6.06

I was reconfig all communication DeviceNet with  RIO in new controler. All devices works .DSQC 350 is not .

This is part ofold old EIO confiration file

EIO:CFG_1.0:3:1::
#
EIO_UNIT_TYPE:

      -Name "IBD816E" -VendorId 256 -VendorName "Lumberg" -DeviceType 7\
      -ProductId 1217 -ProductName "IBD-8/16E" -MajorRev 6 -MaxDigin 8\
      -MaxDigout 0 -MaxAnin 0 -MaxAnout 0

      -Name "IBD8A" -VendorId 256 -VendorName "Lumberg" -DeviceType 7\
      -DeviceDriver "DNGeneric" -ProductId 2161 -ProductName "IBD-8A"\
      -MajorRev 6 -MaxDigin 0 -MaxDigout 8 -MaxAnin 0 -MaxAnout 0
#
EIO_UNIT:

      -Name "BOARD10" -Type "d328" -Bus "BASE" -Digin 16 -Digout 16

      -Name "BOARD11" -Type "d350" -Bus "BASE" -Address "11" -Digin 34\
      -Digout 32 -PollRate 100 -Param "BOARD11_VALUES"

      -Name "Lmbrg_In" -Type "IBD816E" -Bus "BASE" -Address "20" -Digin 8

      -Name "Lmbg_OUT" -Type "IBD8A" -Bus "BASE" -Address "30" -Digout 8

      -Name "Dummy" -Type "eip000" -Bus "SIM" -Address "" -Digin 16 -Digout 16

#
BOARD11_VALUES = EIO_PARAM_VALUE:

      -Name "LinkAddr" -Value "1"

      -Name "DataRate" -Value "2"

      -Name "StartQ" -Value "3"

      -Name "RackSize" -Value "0"

      -Name "LastRack" -Value "0"




This is new EIO configuration file

EIO:CFG_1.0:6:1::
#
INDUSTRIAL_NETWORK:

      -Name "DeviceNet" -Label "DeviceNet Master/Slave Network" -Address "2"

      -Name "DeviceNet_Anybus" -Label "DeviceNet Anybus Network" -Address "40"
#
DEVICENET_DEVICE:

      -Name "BOARD10" -VendorName "ABB Robotics"\
      -ProductName "24 VDC I/O Device" -Label "DSQC 652 24 VDC I/O Device"\
      -Address 10 -ProductCode 26 -DeviceType 7 -ConnectionType "COS"\
      -OutputSize 2 -InputSize 2

      -Name "BOARD11" -VendorName "ABB Robotics" -ProductName "RIO Adapter"\
      -Label "DSQC350" -Address 11 -ProductCode 6 -DeviceType 7\
      -ProductionInhibitTime 100 -OutputSize 4 -InputSize 4

      -Name "Lmbrg_In" -VendorName "Lumberg" -ProductName "IBD816E"\
      -Label "IBD-8/16E" -Address 20 -VendorId 256 -ProductCode 1217\
      -DeviceType 7 -ProductionInhibitTime 100 -OutputSize -1 -InputSize 2

      -Name "Lmbg_OUT" -VendorName "Lumberg" -ProductName "IBD-8A"\
      -Label "IBD8A" -Address 30 -VendorId 256 -ProductCode 2161 -DeviceType 7\
      -ProductionInhibitTime 100 -OutputSize 1 -InputSize -1

      -Name "Dummy" -Simulated
#
DEVICENET_COMMAND:

      -Name "LinkAddr" -Device "BOARD11" -OrderNr 1\
      -Path "6,20 64 24 01 30 01,C6,1" -Value "1"

      -Name "DataRate" -Device "BOARD11" -OrderNr 2\
      -Path "6,20 64 24 01 30 02,C6,1" -Value "2"

      -Name "StartQ" -Device "BOARD11" -OrderNr 3\
      -Path "6,20 64 24 01 30 03,C6,1" -Value "3"

      -Name "RackSize" -Device "BOARD11" -OrderNr 4\
      -Path "6,20 64 24 01 30 04,C6,1" -Value "0"

      -Name "LastRack" -Device "BOARD11" -OrderNr 5\
      -Path "6,20 64 24 01 30 05,C6,1" -Value "0"
#
DEVICENET_INTERNAL_DEVICE:

      -Name "DN_Internal_Device" -VendorName "ABB Robotics"\
      -ProductName "DeviceNet Internal Slave Device"
#
DEVICENET_INTERNAL_ANYBUS_DEVICE:

      -Name "DN_Internal_Anybus" -VendorName "ABB Robotics"\
      -ProductName "DeviceNet Internal Anybus Slave Device"

What wrong  in d350 (BOARD11) configuration ?

Best Answer

Answers

Sign In or Register to comment.