Targets changing

Rickytre91
edited April 2019 in RAPID Programming
I'm having an issue with our Robot system i don't know where this topic falls under hope y'all can help me with this here. Every time we run the same programs our rob targets change. I check the pDispset value and the wobj has moved when it shouldn't have. No collisions have occurred, tcp is fine and we are always calibrating the system to see if this helps. Has anyone else had this problem if so can you tell me how to fix this ? My supervision want us to reduce the time we have to modify target cause its lost time and costing us money

Comments

  • lemster68
    lemster68 United States ✭✭✭
    "we are always calibrating the system to see if this helps."  I hope that does not mean fine calibration.  That should only be done after a motor is replaced.  Checking rev counters is OK.  Do your calibration offsets match?  Is this a program that you are manually or automatically loading?
    Lee Justice
  • what i mean by calibrating the system is modifing bullseye and checking tcp and it is a program that is automatically loaded  
  • Dmitry
    Dmitry ABB Latvia
    Try to find source of error.
    Define target that is static in world relative to robot. When you will have problem again, check that target. If it's ok, then the robot is ok.
    What is your workobject ? Positioner's plate? Its a welding station?
  • Hello. Any more information on this. 
    Did you resolve your problem?
    I am having the same problem.
    When i go back to a programme my points are all out. Is there some simple information i am missing out to.
    TCP Check is constantly be Checked. 

    Thnaks very much.


Sign In or Register to comment.