RobotStudio event

"Move Along Path: Command failed. Check the controller status." Error

Hello all,
     So here is the exact chain of command that i went through and ended up in this predicament that personally doesn't make any sense. (within a virtual station)
1. created 13 easily achievable points for an IRB2400 to go to
2. auto-configured the points as to assure that the points are achievable within a path
3. auto-configure runs fine
4. try to run the path, and the whole software hangs up for a while.
5. try and see if i'm running too many things and its bogging down the software; this wasnt the cause, since i closed several open programs.
6. tried to close and open robotstudio and run the path again, "Move Along Path: Command failed. Check the controller status." appears!
7. delete path, re-instantiate the path using prior points, try and run the path, "Move Along Path: Command failed. Check the controller status."
8. tried to run a prior path within the simulation, this works
9. synchronized to rapid and then hit run simulation, it works and is able to continually run the path with no errors
10. tried to run other paths that have worked in the past and those dont work either, but they run fine in sim or through RAPID

at this point i have zero idea whats wrong, everything except running just the points without using a module works.

if any of you have any ideas, id love to hear them.

thank you,


  • Hi nquattro,

    I had a similar problem when I tried to use the "Execute move command" instruction under the paths and targets menu.
    1. Make a backup of your robot
    2. Remove the controller from the station
    3. Make a new virtual controller
    4. Restore the controller from the backup that you made

    I am assuming this happens when some files in the virtual controller directory become corrupt. 

    Hope this helps.