How do I fix "Mechanism data not found" message in new system?

CeloCelo Saskatchewan
Hi robot guys,

I created a new system from layout but I'm having some issues when using the Arcwelding Powerpac. This message keeps showing up whenever I move the robot.



After creating a weld instruction, and I jump into a target, an error message like this shows up.



As soon as I hit the OK button, the configuration automatically sets itself, and then I'm able to move through my program.



I know this isn't supposed to happen because I have used the powerpac in other pre-created virtual stations and RobotStudio automatically sets the configuration of new targets. Did I miss anything when I created my system? The options I checked are shown below.




Thanks in advance!

Celo

Answers

  • SweMikeSweMike Sweden
    Did you ever solve this? i happend to have the exact same problem!
  • CeloCelo Saskatchewan
    Sorry I haven't found the solution for this yet. What I've been doing is just teaching all the targets first, then using the auto configuration command so I don't have to set the configuration for each one. Let me know if you figure out how to fix it. Thanks! 
  • RobotnisseRobotnisse Sweden
    How do you use the autoconfig, i guess you talk about the autoconfig under home/paths&targets? becaus when im in arcweld i cant seem to find that option, do i need to set everything out in powerpac then shut it down and use autoconfig?
  • CeloCelo Saskatchewan
    Yes I use the auto config under Home>Paths&Targets tab. You don't need to close the powerpac when you do it.
  • RobotnisseRobotnisse Sweden
    hmm, can you post a screenshot of the autoconfig? i just find "Configuration" but no where does it mention auto
  • RobotnisseRobotnisse Sweden
    edited June 4
    nevermind i found it now :)

    edit: man thank you so much, this saves me so much time!  :D
    Post edited by Robotnisse on
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!