RobotStudio event

71367, No communication with I/O unit and 71424, DeviceNet Lean bus off


I have a problem,I am getting this message: No communication between I/O unit Board10 with address 10 on the I/O bus DeviceNet_Lean. I checked addresses and everything seems ok configured and also well wired, I saw one answer about this problem, that I have to connect resistor on DeviceNet, I tried it and connect resistor betweent 2. and 5. pin on on DevicNet but then i got this message: 71424, DeviceNet Lean bus off. Maybe I should wired it on other pins? I have festo gripper EHPS 20A and I use ABB IRB120 and controller IRC5 compact, gripper is not yet connected but I don't think that is problem because it can't give any output signals since it has this problem. And also, I checked X2 pins in controller and on pin 9 is (0V) and on 10 is (24V), but other pins of outputs(1-8) didn't gave voltage


  • what is the status of the NS and MS LED's on the DSQC 652 I/O unit?
  • basic_mihovil
    edited June 2019
    I had  little bit of problem reaching to DSQC652, but I finally managed to find MS and NS and it seems that only MS is on
  • Check you have power on the X5 connector (DeviceNet and address connection) Pin 1 = 0 VDC, pin 5 = 24 VDC.

  • I checked it and it didn't have voltage on it although there are cables connected to first five pins on X5. Is there any switch inside controller or something that I should turn on,because I am confused, cables are connected and there is no voltage. Also if you checked my first picture you can see that I connected cables on X1 on pin 9.(black) and 10.(red) and then i got 24 VDC but under those two cables there are two blue cables which are connected to X2 also pins  9. and 10. and X2 is connected with bridge with X1( if I am not wrong) so i disconnected cables on X1 (pin 9. and 10.) and I didn't get any voltage neither on X2(9. and 10.) neither on X1(9.and 10.)
  • These are two different things:

    -the 0 & 24 VDC to X1 / X2 (they are internally connected) is to power the digital outputs (also need 0 VDC on X3/ / X4 pin 9 for the digital inputs to work).

    -the 0 & 24 VDC to X5 is the DeviceNet power, it should have wire number 248 going to pin 1 and wire 247 going to pin 5.

     These two wires run to the X4 connector on the DSQC662 power supply, check the wires are still connected, and the plug is fully engaged.

    Could be a faulty power supply or there is a short in the 24 VDC wiring causing the power supply to shut down to protect itself.

  • Hi, again

    I took a little break, but I solved the problem, it was both, outputs weren't supplied and terminating resistor was missing between CAN-H and CAN-L. Thank you :) .But now I am interested how to synchronize smartcomponents to real controller or is there some other thing to do. I connected my gripper(FESTO EHPS 20A) to power supply and I gave to gripper outputs, I can give to it signal to open jaws and to close them, it works, but how can I do that automatically. E.g. I give to robot path to do and in specific moment to open/close jaws. Because when I go to Event menager in RS I can only give to my mechanism virtual signal, not one from real controller(IRC5). Do I need maybe name virtual signal same as real one(e.g. both DO10_1)  and than synchronize it to RAPID?
  • You do not use Smart Components in the real controller (as you have the real item, sensor, etc).

    In your RAPID program when you get to the position you want to open/close your gripper (should have zone type fine) use the command SetDO to make the required signal(s) 1 or 0.

  • I understand, thank you very much
  • I am sorry for all of my questions, this should be the last one. My code goes right until one point, then robot stops and this messagge occures: "Out of interpolation objects". Do you know what should I do?
  • This is due to the speed being very slow.

    As suggested in the error message increase the value of the 'Use Additional Interp. Object Batch' system parameter by 1 in the motion planner parameter in the motion config file.