End of interpolation object, error code 50426

Hi,

Sometimes when the robots are up and running i get this message:

End of interpolation object,

The maxmimum ammount of avaible interpolationo obejcts has ben reached.
This can happend if the dynamic performance settings are set to a very low value,
for example trough the command Accset or Pathacc blabla.

I use one Accset per task in the beginning of my programs with a value of "Accset 50,100;"

i have tried different values but with no luck. when this happend i have to lower the speed to 25% to be able to continue, running movements with a velocity of 1k.
what im trying to achive is a slow rampup accerleration to be kinder to the external track gears and motors but also for smooth movement.

attached a picture with arrows to visualise..

Error messeage in swedish.



When the robots accelerates from cleaning station to the left at a velocity of 1k and in 100% speed mode the problem occours.

Best Answer

Answers

  • lemster68
    lemster68 United States ✭✭✭
    So have you actually used the accset instruction?
    Lee Justice
  • j_proulx
    j_proulx United States ✭✭
    Here is the Error from the manual:

    50426, Out of interpolation objects
    Description
    The maximum number of available interpolation objects has been reached. This can occur if the dynamic performance is
    set to a very low value for example by use of the AccSet or PathAccLim command.

    Consequences
    The program execution is stopped and the system goes to Motors Off state.

    Recommended actions
    Increase the number of objects by increasing the value of the 'Use Additional Interp. Object Batch' system parameter by 1,
    in the corresponding instance of type Motion Planner in topic Motion.
    !!!!!!!!!!

    Did you try the recommended Action?


  • lemster68
    lemster68 United States ✭✭✭
    edited September 2019
    lemster68 said:
    So have you actually used the accset instruction?
    Duh!  I should have read the first post better, I see now that you said that originally.  I prefer to use the second number, i.e.. AccSet 100,50;  Seems more effective.  I will reduce both numbers at times, too.  Follow up on j_proulx's advice too.
    Lee Justice
  • hmm have not tested 100,50. i will try that!

    And to answer the second question, i have not done that, to be honest i dont know where to find the motion planner ^^
  • Robotdude
    Robotdude Sweden
    Changed the values in the motion planner and havent had a problem since that :)