Connection to robot through service port unstable

We recently have been commissioning an update to an older cell with ABB robots using Robotware version 5.09.3029.03, in case that matters. 
When we try to connect our laptops to the robot controller to make changes in RobotStudio, the ethernet connection is either not detected by Windows at all, or it is intermittently detected for a fraction of a second at a time, once every few seconds. This happens for all but one of our computers, and on those computers it happens on every robot in the plant (at least the ones we've tried that is). We have compared the network protocol settings between these computers and found no differences in IP configuration or anything. The only difference we can find is the hardware network card itself; the computers that do NOT work have an Intel integrated network card, listed in the device manager as "Intel(R) Ethernet Connection I217-LM", using driver number 12.13.17.7. The computer that DOES work has a Realtek network card, the details of which I cannot remember off the top of my head.

Has anyone else experienced problems with this particular network card/driver? Has anyone had similar problems with other network cards? Could this be related to something other than the hardware network device? Would using a USB network adapter bypass any issues related to the integrated network device?

Unfortunately our office is a few hours away from the plant so I will not be able to test any recommendations immediately. But any advice on troubleshooting paths or potential solutions would be appreciated.

Comments

  • graemepaulingraemepaulin New Zealand ✭✭✭
    edited December 2019

    What main computer does the system have - the top snip is DSQC623 and bottom snip is DSQC639?

     

  • j_proulxFBj_proulxFB Watertown, WI USA
    I have the same issue. Intel(R) Ethernet connection I219V. The ethernet connects for a fraction of a second and then drops out. Cannot use my ethernet port to hard-wire to Service Port on any controller.
    I am able to use a USB to Ethernet adapter to hard-wire connect to any controller. My IT has looked at this and can't explain it. 
  • As a test have you tried setting up a static IP in the correct range for the Service Port?

    I set a static IP of 192.168.125.123 with a mask of 255.255.255.0 on and open gateway to get rid of the DHCP assignment delay when moving around a line of ABB controls.
  • ThomasMartinAiutThomasMartinAiut Greenville SC
    edited December 2019
    graemepaulin I'm not sure off the top of my head, I'll try to find out. Do you have an idea of what the problem might be?
  • ThomasMartinAiutThomasMartinAiut Greenville SC
    SomeTekk I have tried using auto IP config and I have tried manually setting a static IP, both had the exact same problem
  • ThomasMartinAiutThomasMartinAiut Greenville SC
    j_proulxFB Weird. In an odd way it's comforting to know that someone else has experienced this. And that is fantastic that a USB adapter works, we will order some ASAP. Thanks!
  • graemepaulingraemepaulin New Zealand ✭✭✭

     Unfortunately I have no idea what the issue is, and searching the internal ABB support database regarding this reveals that over the years there have been issues connecting to the older main computers with current generation computers/ laptops. None of them had any resolution, though some did say that simply by using a different make or model of computer a connection could be made, which ties with your experience.

    One thing with the DSQC623 (and similar looking but older DSQC600) main computers is you need to use a cross over cable. With the DSQC639 and later main computers you can use a straight through patch cable or a cross over cable.

    I also did not know that using a USB adapter solves the issues - thanks James :-)


  • Here's some info regarding Network Settings, in case they have not been looked at yet, or if a Windows update reconfigured various settings:

    Prerequisites

    The PC can be connected to the controller through an Ethernet network in the following ways:

    • Local network connection

    • Service port connection

    • Remote network connection

    Local network connection

    You can connect your PC to the same Ethernet network that the controller is connected to. When the PC and the controller are connected correctly and to the same subnet, the controller will be automatically detected by RobotStudio. The network settings for the PC depend on the network configuration. Contact the network administrator for setting up the PC.

    Service port connection

    When connecting to the controller's service port, obtain an IP address for the PC automatically, or specify a fixed IP address. Contact the network administrator for setting up the service port connection.

    Automatic IP address

    The controller's service port has a DHCP server that will automatically give the PC an IP address if it is configured for this. For detailed information, see the Windows help on configuring TCP/IP.

    Fixed IP address

    Instead of obtaining an IP address automatically, you can also specify a fixed IP address on the PC you connect to the controller.

    Use the following settings for a fixed IP address:

    Property

    Value

    IP address

    192.168.125.2

    Subnet mask

    255.255.255.0

    For detailed information about how to set up the PC network connection, see Windows help on configuring TCP/IP.

    Note

    Obtaining an IP address automatically might fail if the PC already has an IP address from another controller or Ethernet device. To ensure the accuracy of the IP address if the PC was connected to an Ethernet device, do one of the following:

    • Restart the PC before connecting to the controller.

    • Run the command ipconfig /renew from the command prompt after connecting the PC to the controller.


    Remote network connection

    To enable connection to the controller on a remote subnet or over the local network, the relevant network traffic must be allowed through any firewall between the PC and the controller. The firewall must be configured to accept the following TCP/IP traffic from the PC to the controller:

    • UDP port 5514 (unicast)

    • TCP port 5515

    • Passive FTP

    All TCP and UPD connections to remote controllers are initiated by the PC, that is, the controller only responds on the given source port and address.

     
  • ThomasMartinAiutThomasMartinAiut Greenville SC
    graemepaulin I'm fairly confident that we used a cross-over cable, but I will confirm that and make sure that we have one when we re-visit the plant after Christmas. Thanks
Sign In or Register to comment.