RS2019.5: Fail to backup controller unpacked

DenisFR
DenisFR FRANCE ✭✭✭
edited January 2020 in UpFeed
Hello,
On station unpacked with more than 1 controller, when I save it, controllers failed to make backups:
11223: Backup error
Description
Error during the backup of Task.
The directory lacks at least one necessary item.
Consequences
The backup request is aborted.
No backup was created.
How to reproduce:
1- Create new solution with station and virtual controller (IRB_6700_205kg_2.80m / 6.08.01.00)
2- Add new controller
3- Save (all works here)
4- Create a Pack and Go
5- Close RS
6- Open rspag file and unpack it in new target
7- Modify station by adding an empty part or else
8- Save station...
Backup failed for the two controllers.

When enabling controller to log to a console window, I've got:
C1:
[ROBRSP] <Got storage pointer 0x49fbb8a0>
Backup requested via RobAPI. Path: C:/Users/user/AppData/Local/Temp/5fab87d0, Include: 0xFFFF
20-01-17  14:08:13 MC0(barts): d:\workspaces\robotsoftware\kernel\6.08.xx\areas\systemdirector\components\bar\bar_backup.cpp 2024 Error while validating backup: -73
20-01-17  14:08:13 MC0: type = ERROR id = Operational code = 1223 (11223)
arg 0: 2 arg 1: -73 arg 2: 248
20-01-17  14:08:13 MC0: type = ERROR id = Operational code = 1261 (11261)
arg 0: C:\Users\user\Documents\RobotStudio\Solutions\TestMultiRobots2\Virtual Controllers\TEMP\1579266265\backup.085502

C2:
[ROBRSP] <Got storage pointer 0x49fbb8a0>
Backup requested via RobAPI. Path: C:/Users/user/AppData/Local/Temp/145f7c90, Include: 0xFFFF
20-01-17  14:08:13 MC0(barts): d:\workspaces\robotsoftware\kernel\6.08.xx\areas\systemdirector\components\bar\bar_backup.cpp 2024 Error while validating backup: -73
20-01-17  14:08:13 MC0: type = ERROR id = Operational code = 1223 (11223)
arg 0: 2 arg 1: -73 arg 2: 248
20-01-17  14:08:13 MC0: type = ERROR id = Operational code = 1261 (11261)
arg 0: C:\Users\user\Documents\RobotStudio\Solutions\TestMultiRobots2\Virtual Controllers\TEMP\1579266265\backup.478386
%temp% folders are not created (maybe cleaned) only empty \Virtual Controllers\TEMP\1579266265.

Comments

  • DenisFR
    DenisFR FRANCE ✭✭✭
    Other case:
    1- Create new solution with station and virtual controller (IRB_6700_205kg_2.80m / 6.08.01.00)
    2- Add new controller
    3- Save (all works here)
    4- Create a Pack and Go
    5- Close RS
    6- Reopen station
    7- Modify station by adding an empty part or else
    8- Save station...
    Only first controller are backed other one doesn't received Backup requested via RobAPI.
    I cannot change controller operation mode either. I've got Timeout error:
    RobotStudio .NET exception: C0040403 : No response from controller.
    Timeout
    Url:  Cmd:Get  Prop:Mode  Args:  Elapsed:19991  CurrentCmds:4
    History:
    -00:06:35.2405879 [738] status:SYS_CTRL_S_OK data:TRUE
    -00:03:02.1860638 [747] Subscribe url= prop=BackupSub arg=
    -00:03:02.1860638 [748] SendCommand url: cmd:Set prop:Backup arg:-Path "C:/Users/user/AppData/Local/Temp/725301b0"
    -00:02:45.4085605 [747] status:2147549183 data:Subscribe eventid error 0x0 != 0x14c34cd4 url=/127.0.0.1/ hr=0x8000ffff f=c:\bui...
    -00:01:24.0191970 [754] SendCommand url:/MOTIONSYSTEM/MECHUNITS/ROB_1 cmd:Set prop:MechUnitPosition arg:-Pose 30.61856,0,0,0,30,0,0,0,0,0,0,0
    -00:01:09.2044807 [757] Subscribe url= prop=BackupSub arg=
    -00:01:09.2044807 [758] SendCommand url: cmd:Set prop:Backup arg:-Path "C:/Users/user/AppData/Local/Temp/2a93da9c"
    -00:00:56.4711628 [754] status:ROB_E_TIMEOUT data:Timeout TIMEOUT
    -00:00:56.4371349 [763] SendCommand url:/MOTIONSYSTEM/MECHUNITS/ROB_1 cmd:Set prop:MechUnitPosition arg:-Pose 30.61856,0,31.03093,0,30,0,0,0,0,0,0,0
    -00:00:44.3788149 [757] status:2147549183 data:Subscribe eventid error 0x0 != 0x14c34cd4 url=/127.0.0.1/ hr=0x8000ffff f=c:\bui...
    -00:00:36.2391591 [764] SendCommand url:/CONFIG cmd:Get prop:Childs arg:-mark 0 -noelts -1 -cc 0
    -00:00:34.0023948 [763] status:ROB_E_TIMEOUT data:Timeout TIMEOUT
    -00:00:34.0023948 [765] SendCommand url:/MOTIONSYSTEM/MECHUNITS/ROB_1 cmd:Set prop:MechUnitPosition arg:-Pose 30.61856,0,31.03093,0,63.09278,0,0,0,0,0,0,0
    -00:00:32.9943479 [766] SendCommand url: cmd:Get prop:IsOptionPresent arg:-Option KLMODESWITCH
    -00:00:17.6209443 [764] status:ROB_E_TIMEOUT data:Timeout TIMEOUT
    -00:00:15.8135474 [765] status:ROB_E_TIMEOUT data:Timeout TIMEOUT
    -00:00:14.9903327 [766] status:ROB_E_TIMEOUT data:Timeout TIMEOUT
    -00:00:14.4764457 [767] SendCommand url: cmd:Get prop:Mode arg:
    -00:00:11.1617891 [770] SendCommand url: cmd:Get prop:IsOptionPresent arg:-Option KLMODESWITCH
    00:00:00 [767] status:ROB_E_TIMEOUT data:Timeout TIMEOUT

    ============================================
    Base exception: RobApiException
    C0040403 : No response from controller.
    Timeout
    Url:  Cmd:Get  Prop:Mode  Args:  Elapsed:19991  CurrentCmds:4
    History:
    -00:06:35.2405879 [738] status:SYS_CTRL_S_OK data:TRUE
    -00:03:02.1860638 [747] Subscribe url= prop=BackupSub arg=
    -00:03:02.1860638 [748] SendCommand url: cmd:Set prop:Backup arg:-Path "C:/Users/user/AppData/Local/Temp/725301b0"
    -00:02:45.4085605 [747] status:2147549183 data:Subscribe eventid error 0x0 != 0x14c34cd4 url=/127.0.0.1/ hr=0x8000ffff f=c:\bui...
    -00:01:24.0191970 [754] SendCommand url:/MOTIONSYSTEM/MECHUNITS/ROB_1 cmd:Set prop:MechUnitPosition arg:-Pose 30.61856,0,0,0,30,0,0,0,0,0,0,0
    -00:01:09.2044807 [757] Subscribe url= prop=BackupSub arg=
    -00:01:09.2044807 [758] SendCommand url: cmd:Set prop:Backup arg:-Path "C:/Users/user/AppData/Local/Temp/2a93da9c"
    -00:00:56.4711628 [754] status:ROB_E_TIMEOUT data:Timeout TIMEOUT
    -00:00:56.4371349 [763] SendCommand url:/MOTIONSYSTEM/MECHUNITS/ROB_1 cmd:Set prop:MechUnitPosition arg:-Pose 30.61856,0,31.03093,0,30,0,0,0,0,0,0,0
    -00:00:44.3788149 [757] status:2147549183 data:Subscribe eventid error 0x0 != 0x14c34cd4 url=/127.0.0.1/ hr=0x8000ffff f=c:\bui...
    -00:00:36.2391591 [764] SendCommand url:/CONFIG cmd:Get prop:Childs arg:-mark 0 -noelts -1 -cc 0
    -00:00:34.0023948 [763] status:ROB_E_TIMEOUT data:Timeout TIMEOUT
    -00:00:34.0023948 [765] SendCommand url:/MOTIONSYSTEM/MECHUNITS/ROB_1 cmd:Set prop:MechUnitPosition arg:-Pose 30.61856,0,31.03093,0,63.09278,0,0,0,0,0,0,0
    -00:00:32.9943479 [766] SendCommand url: cmd:Get prop:IsOptionPresent arg:-Option KLMODESWITCH
    -00:00:17.6209443 [764] status:ROB_E_TIMEOUT data:Timeout TIMEOUT
    -00:00:15.8135474 [765] status:ROB_E_TIMEOUT data:Timeout TIMEOUT
    -00:00:14.9903327 [766] status:ROB_E_TIMEOUT data:Timeout TIMEOUT
    -00:00:14.4764457 [767] SendCommand url: cmd:Get prop:Mode arg:
    -00:00:11.1617891 [770] SendCommand url: cmd:Get prop:IsOptionPresent arg:-Option KLMODESWITCH
    00:00:00 [767] status:ROB_E_TIMEOUT data:Timeout TIMEOUT

       at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
       at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
       at RobotStudio.Services.RobApi.RobVcPanel.<SetOperatingModeInternal>d__24.MoveNext()
    --- End of stack trace from previous location where exception was thrown ---
       at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
       at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
       at RobotStudio.Services.RobApi.RobVcPanel.<SetOperatingMode>d__23.MoveNext()
    --- End of stack trace from previous location where exception was thrown ---
       at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
       at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
       at RobotStudio.UI.Controller.VCPanelSmall.<RadioButton_CheckedChanged>d__4.MoveNext()

  • Maxim Riabichev
    Maxim Riabichev Sweden admin
    Thanks for the report and the clear reproduction steps.

    We'll look into this issue.

    Maxim Riabichev
    PC Software Support Engineer