Joint Out of Range Error

TomásPTTomásPT Portugal
Hello!

I am finishing a station and when I run the path main I get the error "Joint Out of Range". Every time I run it appears to me either on ROB2 or ROB3 (the ones on the right). I have the action confL \ off on all paths.
Can someone help me ?

Below I show what happens.


Thank you.

Comments

  • graemepaulingraemepaulin New Zealand ✭✭✭
    This is because you have turned off using the stored robot configuration.

    You can use the auto configuration (right click on the path in the home tab tree) to set all the targets in the path's configuration-you have to set the first one manually  then it does the rest.
    It can take a few tries where you have to manually change the configuration of the first target to a different configuration and re run the auto config - as the robot can not make it all the way through the path with out running out of range on a joint. 
    You can think of this as winding some of the axis up backwards so they have more total range to work through as the path progresses.

    Some times you may have to split a path because there in now solution that works.

  • TomásPTTomásPT Portugal
    edited June 8
    Well I set up the first point manually and applied autopath so far so good and without errors, but when I run in the simulation the same error still appears :( The targets stay with the correct configuration but somehow the problem continues to appears...

    Is there another way to solve it?


  • Anders SAnders S Sweden mod
    You need to remove the instruction 'ConfL\Off' from the main procedure to use the new configurations (and of course sync to RAPID).
    Best regards,
    Anders Spaak
    ABB Robotics
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!