Problem with PaintApplicator SmartComponent

Hello everybody,

I'm a beginner using RobotStudio and I'm stuck with this problem.

I'm trying to programme a paint shop for vehicles, for my Master's Dissertation. I have a 3D CAD model of a vehicle (like in the following picture), that I have converted to STL format, and I have imported it to RobotStudio.


To simulate the application of the paint over the different components I have used the PaintApplicator SmartComponent, but when I have tried to select the component that is going to be painted it didn't keep selected. I mean, the component appears in the Part section of the SmartComponent properties menu and I can select it, but after I select it and I apply the changes, it doesn't remain selected, so the PaintApplicator doesn't have any part to apply the paint and it doesn't work. 
I have tried the same with simple solids created with the modeling option of RobotStudio and in this case it worked fine. 

Does someone know why the PaintApplicator doesn't keep selected the part? Could it be due to file format or the import geometry procedure? I have tried with other file formats and I have had the same problem.

Is this the only way to simulate the application of the paint or are there other methods?

Thanks a lot!

Comments

  • EricHEricH Germany
    I used to some extend the paint applicator and it has definetely some issues, but never this one. Try SAT or STP formats, those work for me.
Sign In or Register to comment.