Can not jog - Error during jogging

PetrBPetrB Czech
Hello,

sometimes when I select certain tool and wobj, I can't jog the robot. On jogging screen it displays "Mechanical unit is not calibrated or a coordinated unit is not activated.", when I try to jog the robot, it gives me the error "Error during jogging". Error goes away by itself after some playing around.


Comments

  • lemster68lemster68 United States ✭✭✭
    What do you mean by "playing around"?  Change tool, workobject?  Change to joint jog?
    Lee Justice
  • Did you go through the process of mastering the robot? Looks like it hasn't been mastered, or mastered improperly 
  • PetrBPetrB Czech
    edited September 2020
    I'm not 100% sure what I did to fix it, I just kept working on something else and suddenly it start working.

    If by mastering you mean calibration, then yes, I calibrated it when robots were delivered. In calibration menu, it shows both robots are calibrated.

    I'm experiencing this behavior only with one wobj, with others it's fine. Robots are working correctly, no issues at all.
  • lemster68lemster68 United States ✭✭✭
    Are any of your workobjects held by the robot?  ROBHOLD:=TRUE  On the Other hand, any tools not held by the robot?  It used to report something like "robhold confusion fault"  Both workobject and tool cannot both be held.
    Lee Justice
  • PetrBPetrB Czech
    All my tools are held by robot (robhold:TRUE), none of my wobj is held by robot (robhold:FALSE)

  • lemster68lemster68 United States ✭✭✭
    OK, next question...is the workobject moved by a mechanical unit?
    Lee Justice
  • PetrBPetrB Czech
    No my wobj is stationary (stationary table with clamps, robot is doing ultrasound welding on bumper with exchangeable  welding heads).
  • PetrBPetrB Czech
    I found out what was wrong. I have multimove system and wobj for both robots had same name, although they've been declared as TASK PERS. Changing wobj name to unique name helped.
Sign In or Register to comment.