Axis 4,5 and 6 won't move in reduced speed in Automatic Mode

moondhirmoondhir 101 Roytec Rd B, Woodbridge, ON L4L 8A9

I’m an Automation and Robotics Technician intern with DuROCK Alfacing International Limited. I’m working with ABB IRB6640 M2004 robot 

 I programmed the robot to depalletize bundles stacked on a skid to a conveyor line. When I switch the robot to Automatic Mode and reduce the speed to 50% , axes 1, 2 and  3 move at the reduced speed but axes 4,5 and 6 still move at 100% speed and not the reduced speed. For the purpose of our application we need all the axes to move at a 50% reduced speed. Any suggestion to what I should to achieve that ?

Thank you.

 


Comments

  • Try AccSet


  • lemster68lemster68 United States ✭✭✭
    Are you using MoveL or MoveJ?  It sounds to me like you are near singularity with MoveL.  In either case, all axes have to arrive at the programmed destination AT THE SAME TIME, regardless of the programmed speed or speed override.  That is why I suspect singularity.  4 and 6 especially will have to move quite fast, and at 100% probably are maxed out.  At 50% you could likely see them still moving quite fast.  Make sure to avoid singularity and use lower programmed speeds, using the override is not a good option as the robot defaults back to 100% when switched into automatic.  (Unless you know the parameter to prevent that)
    Lee Justice
  • graemepaulingraemepaulin New Zealand ✭✭✭
    The speed in move commands is the TCP speed not the speed of each of the axis so you will not directly be able to slow all the axis down.
    As Lee pointed out with any move all the axis will arrive at the same time so most of the time they will be moving at different speeds to be able to achieve that.
    So to get each axis moving at approximately the same speed you will need to have each move command moving each axis approximately the same number of degrees.
  • j_proulxFBj_proulxFB Watertown, WI USA
    You need to create your own speeddata that slows the reorientation of the wrist axis. The v_ori parameter needs to be reduced. This is how you control your wrist speed in palletizing.
Sign In or Register to comment.