RS closes when inserting IRC5 controller

AlvaroV
AlvaroV Spain
Hi everyone!

I just installed RobotStudio 2020.4 and added the latest versions of both RobotWare for IRC5 and omnicore. When I create an empty station, I can insert the robots and jog in the virtual world but whenever I try to insert the virtual controller with RobotWare for IRC5 (with omnicore there's no problem), the sw freezes and closes down. Same thing happens when I try to create the station with the controller from the beginning. I have already tried many times to reinstall both RobotWare and RobotStudio but I can't figure out how to solve it. ¿Does anyone know what the solution to my problem is? 

Thanks in advance,

Alvaro

Comments

  • Maxim Riabichev
    Maxim Riabichev Sweden admin
    Hello Alvaro,

    Please use the RobotStudio Support Tool and generate a report.
    When it's generated, open the archive and take a look in the folder called ErrorLogs.
    Open the latest log and try to locate the error/exception.

    Please post the error/exception here.

    Important: Do not post the whole report (the archive) here, as it contains sensitive information.

    Maxim Riabichev
    PC Software Support Engineer
  • AlvaroV
    AlvaroV Spain
    Hi Maxim,

    Thanks for answering so fast. I think that these are the lines that asked me for:

    ----LOG BEGIN----
    00:00:13.2432619|UIThreadWatchdog|Started
    00:00:27.5925805|GraphicsFeatureLevel|D3D_FEATURE_LEVEL_11_0
    00:00:28.5544297|UIThreadWatchdog|Warning|2000 ms delay on UI thread
    00:00:29.1991915|BackstageVisibilityChanged|False
    00:00:30.1934976|StationCreated
    00:00:30.3600817|ActiveWindowChanged|GraphicWindow|NoId
    00:00:30.5653792|UIThreadWatchdog|Warning|4000 ms delay on UI thread

    Thank you. Regards.

    Alvaro
  • Maxim Riabichev
    Maxim Riabichev Sweden admin
    Hello there,

    Unfortunately there's no error / exception shown in this paste.

    Please see if you can find something that starts with : 

    ----EXCEPTION BEGIN----

    And ends with:

    ----EXCEPTION END----

    Paste that section please.

    Maxim Riabichev
    PC Software Support Engineer
  • AlvaroV
    AlvaroV Spain
    Hi Maxim,

    The issue is that there is no Exception in the ErrorLog since RS just freezes and closes down without showing any message. 

    Thanks for anwering,

    Alvaro
  • Maxim Riabichev
    Maxim Riabichev Sweden admin
    Hello Alvaro,

    Do you have administrator privileges on your PC?
    Are you installing RobotStudio as administrator?

    It's very difficult to troubleshoot something without any error logs, which is why I'm asking these basic questions.

    Can you take a look in the task manager if you can see a process called ABB Virtual RobotController after trying to start a Virtual Controller in RobotStudio (before it crashes/as it crashes)?

    Maxim Riabichev
    PC Software Support Engineer
  • AlvaroV
    AlvaroV Spain
    Hello there,

    It seems that I've been able to solve the problem, for now. Looks like the antivirus was blocking the program whenever I inserted the RW6, although it's quite strange that I could insert RW7. Anyways, thanks for the help.

    Regards,


  • Maxim Riabichev
    Maxim Riabichev Sweden admin
    Ah, the antivirus classic :)

    Glad to hear you found a solution!

    Maxim Riabichev
    PC Software Support Engineer
Sign In or Register to comment.