Fail to cold start

(Irb 6400): S/N= 64-13958

3.1 OS

I have got a problem with this bot. I was on vacation last week so I’m just coming into this mess.

They was in the process of a setup, Weld mods, and reg counts, then had a system fail. I told them to restart

Then they got the disk changed / reread-cancel window after the start up. They did a reread and the was no TCP data.

I told them that we will have to do a cold start on it. They tried and had problems, for some reason the disk 1 was gone from the flash drive. I loaded the dick 1 back on the flash drive , did a cold start, loaded the key disk, then loaded disk 1 then got this error. (error. 03:07003 unexpected interrupt on MC: ) Now every time it boots up is goes to this point and gives me the same error.


I have changed the main computer and memory boards .

I have been in touch with ABB Tech and recommend to try a robot computer board.

We are kinda at a stand still on this. I'm going to check the pin on all the boards and back plain next and try again. We will have to order a robot computer board so I will have to wait for it to come in. 

Comments

  • graemepaulin
    graemepaulin New Zealand mod
    Have checked the internal support case database for this error:
    -disconnect batteries for at least 10 minutes to ensure the memory is empty ->though you have changed memory board so it should have been empty.
    -Memory board failure -> you have changed already, is it a know good spare?
    -Must have correct hardware for the version of RW/OS -> as it was running should not be an issue, but any changed boards must be of the same type.
    -If some one by mistake used a RW/OS 3.2 boot disk then the robot computer board must be replaced.
  • graemepaulin  If the memory or main computer board had a different OS could it cause this problem? The part # was the same as the old boards, also the boards was used, and as far as I know they was working.
  • graemepaulin
    graemepaulin New Zealand mod
    According to one of the cases if the main computer has ever had OS 3.2 loaded it will cause an issue with the Robot Computer.
    But for the memory board the case only said to leave the batteries disconnected for at least 10 minutes which will erase all the contents as it is volatile memory (like RAM in your PC).
  • Ok thanks. We do have another bot that has 3.2 OS I Wasn't here when they first tried to load the key disk.  
  • graemepaulin
    graemepaulin New Zealand mod
    Depending on the hardware in this system you may be able to upgrade to OS 3.2 - would that be all your controllers on OS 3.2 or would there still be a mixture?

    I will see if I can find the document that details the different combinations that work together.
  • we have also have one that runs on 3.0 OS. and we also have a 1400 with a 3.0 OS.
    we are going to have to update soon because parts are becoming hard to find. So hopefully it will be in the next year or two.  
  • Up date on the board, it should be here 3/17/21
  • We got the board today and I have installed it. It started up like it should, I did find out that the flash drive I was using was bad, when I went to load disk 1, it went to the start up screen with the counter. I got a flash drive that i new was good and every thing went fine.
    Thanks for the help.
  • Also I did reinstall the original memory and main computer boards
  • graemepaulin
    graemepaulin New Zealand mod
    Thanks for the update, and good to hear it is all up and running now.
  • bribro12
    bribro12 Belgium
    Hello Graemepaulin and DFulkerson1rcp. I recently bought an ABB IRB 6400 robot with S4C controller and upon cold startup of the controller i get the same error message as DFulkerson1rcp had. So my question is: did you resolve the issue by just reinstalling the robotware/baseware? and were you able to resolve the issue without changing the hardware? Thanks in advance for your time.
  • bribro12 We had to order a new memory board, and I had to get a new flash drive to load the key disks. I'm sure I loaded the wrong OS version, to the unit and messed up the boards. When the problem happen I was on vacation so I'm not sure what OS they loaded, I do know that the flash drive was bad. As of now everything is working well. Also I found the board used on ebay for $45. It was a shot in the dark with the used board but it worked. 
  • bribro12
    bribro12 Belgium
    Thank you very much for your reply DFulkerson1rcp. Which hardware do you have installed in your S4C controller and which board number did you have to replace? My hardware setup is this:
    -DSQC 373
    -DSQC 323
    -DSQC 361
    Which OS version is currently loaded on your system?
    I now ordered a new main computer board (361), but you had to replace the memory board?

    Thanks in advance.
  • The one I replaced was a DSQ324 Memory board. and the OS is 3.1
  • correction I was wrong i didn't change the memory board I just re read every thing again. the memory board was good.

  • it was the  robot computer board that I replaced. 
  • bribro12
    bribro12 Belgium
    Thank you very much for the information DFulkerson1rcp. Well, i ordered the main computer (DSQC 361) since the error was "error. 03:07003 unexpected interrupt on MC" like yours. this one should arrive tomorrow. I'll see what this does and if it doesn't work I'll order a new robot computer as well (DSQC 373). 

    Since this error is probably caused by installing the wrong OS I'm getting a bit anxious about installing the wrong OS. The previous owner gave me a copy of RW2.1 which is now most certainly wrong because the original documentation states the robot was delivered with RW3.1 installed. He might've tried to install the RW2.1 OS which might be the cause of this error in the first place.



    I found a RW3.2 copy in a forum somewhere but I'm not sure if this is the correct one for my setup. https://www.robot-forum.com/robotforum/thread/35443-looking-for-any-old-abb-robot-key-disks-and-robotware-3-2/?postID=152524#post152524

    Would it be possible for you to share your RW3.1 OS files with me?

    Thank you very much already for your help and time.


  • bribro12
    bribro12 Belgium
    The 361 main computer arrived today. I tested it out and unfortunately got the same error.

    I pulled all the cards out again to inspect them more closely and saw someone had tried to re-solder some resistors on the memory board (323). 
    So i either have to order a new robot computer (373) or a new memory board (323). 50/50 chance but I'm bad at gambling so I ordered both of them. 

    Hope a completely new (used) board set (361, 373, 323) will solve the problem.
  • bribro12
    bribro12 Belgium
    The new robot computer board (373) and memory board (323) arrived on monday. I installed them both and the S4C controller booted right up to the screen asking for a key disk. I was able to install the robotware 3.1 first try and the robot was able to move! I had to re-calibrate/ update the rev counters to be able to make linear movments but this didn't take to long. Thank you for the help!

  • Glad to help. Let me know If I can help with anything else.