RobotStudio Crashes Dragging Window

DavidLanham
DavidLanham United States ✭✭
When I open a program from one controller and then right click on the tab and select New Vertical Tab Group.  Then open another Controller program and then try and drag and drop the window to the other Vertical Tab group that I created it will sometimes crash RobotStudio.  Not every time, but a lot enough that I am scared to try and drag windows around.

Comments

  • Maxim Riabichev
    Maxim Riabichev Sweden admin
    Hi David,

    Would you be so kind and provide us a video recording of the issue that also showcases the reproduction steps?

    Thanks!

    Maxim Riabichev
    PC Software Support Engineer
  • Newman
    Newman Sweden
    Hi David,

    Would you be so kind and provide us a video recording of the issue that also showcases the reproduction steps?

    Thanks!
    I have similar problem on my Lenovo laptop, but only on the laptop screen (1920x1080) and not on the external screen (also 1920x1080).

    I attached a recording. RS crashes when I resize a floated window, but only when done "fast".

    -----------------
    David
    Swedish freelance ABB robot programmer
  • Maxim Riabichev
    Maxim Riabichev Sweden admin
    Hi David,

    I've tried to reproduce this issue but have been unable to do so.

    I can resize the floating window extremely fast and it RS doesn't crash.

    Perhaps it could be related to your graphics drivers (big guess)?

    Maxim Riabichev
    PC Software Support Engineer
  • Newman
    Newman Sweden
    Hi David,

    I've tried to reproduce this issue but have been unable to do so.

    I can resize the floating window extremely fast and it RS doesn't crash.

    Perhaps it could be related to your graphics drivers (big guess)?
    Ok, yes probably then. Laptop screen run from amd radeon tm graphics (crashes) and external monitor from NVIDIA GeForce GTX 1650 Ti (works fine).
    /David
    -----------------
    David
    Swedish freelance ABB robot programmer
  • Newman
    Newman Sweden
    @Maxim Riabichev
    I actually figured out a fix for this when scrolling through release notes for RS 2021.3. It was my laptops internal graphic card that was the problem and in the release note there was a tip on how to force external graphic card to be used by uncomment a row in robotstudio.exe.config. I set the value to "Warp".
    BTW, the location of the folder in the release note was not correct, should be:
    C:\Program Files (x86)\ABB\RobotStudio 2021\Bin


    -----------------
    David
    Swedish freelance ABB robot programmer
  • Thanks for the info David!

    Maxim Riabichev
    PC Software Support Engineer