How to access FTP from RobotStudio

Hello all

try to connect to my FTP server on the same machine as robotstudio with no sucsess.

Load\Dynamic,"MyFTPServer:"\File:="main.mod";


Under Motion Configuration i have:
- 614-1 FTP-Client
- 615-1 NFS Client
- 616-1 PC Interface

under Configuration-Communication I have the correct IP address (192.168.0.192). Tried 127.0.0.1 and localhost - nothing.

When I connect from a "real" controller (running robot) it works perfect - so my FTP Server is OK.

Any ideas?
Thanks!



Comments

  • I've never had any success with the FTP-Client option in RobotStudio, connecting with an application like FileZilla however seems to work with no issues. 
  • duesentrieb66
    duesentrieb66 Ontario
    I have problems with FileZilla.

    working:
    -vsFTP (Debian)
    - own Java FTP-Server (Windows/Debian)

    not working:
    - FileZilla (Controller doesn't seem to send the password)
    - own C++ FTP-Server (instead RETR command controller send LIST command)

    I tried several FTP-Clients to access a file from my C++ FTP-Server (integrated into my software) and they all work. So username, password, IP etc must be correct.

    Maybe if you could share the settings of your FileZilla-Server could lead me to the solution?

    Thanks!
  • When I login via FileZilla I don't use a username/password, leaving it blank works just fine. I am using RW 5.15 though
  • duesentrieb66
    duesentrieb66 Ontario
    OK, I'll try. I have same RW

    Here what I get:
    (000042)2021-03-16 9:24:22 AM - (not logged in) (192.168.0.100)> Connected on port 21, sending welcome message...
    (000042)2021-03-16 9:24:22 AM - (not logged in) (192.168.0.100)> 220-FileZilla Server 0.9.60 beta
    (000042)2021-03-16 9:24:22 AM - (not logged in) (192.168.0.100)> 220-written by Tim Kosse ([email protected])
    (000042)2021-03-16 9:24:22 AM - (not logged in) (192.168.0.100)> 220 Please visit https://filezilla-project.org/
    (000042)2021-03-16 9:24:22 AM - (not logged in) (192.168.0.100)> USER abb
    (000042)2021-03-16 9:24:22 AM - (not logged in) (192.168.0.100)> 331 Password required for abb
    (000042)2021-03-16 9:24:22 AM - (not logged in) (192.168.0.100)> PWD
    (000042)2021-03-16 9:24:22 AM - (not logged in) (192.168.0.100)> 530 Please log in with USER and PASS first.
    (000042)2021-03-16 9:24:22 AM - (not logged in) (192.168.0.100)> disconnected.
    (000043)2021-03-16 9:24:25 AM - (not logged in) (192.168.0.100)> Connected on port 21, sending welcome message...


  • duesentrieb66
    duesentrieb66 Ontario
    hmm - are you using FileZilla as a client to access the controller or the Server to access FROM the controller to the FileZilla FTP Server?


  • Access the controller
  • duesentrieb66
    duesentrieb66 Ontario
    ok, I try the other way. Thanks anyways!
Sign In or Register to comment.