PCSDK on WAN port

hi, 

I am currently trying to connect a GoFa with OmniCore control to the PCSDK via network. Unfortunately this does not work. Are there any special settings for this? 
It works fine via the MGMT port, but as soon as I try it via WAN port and a router, the PCSDK does not connect anymore (I can connect RobotStudio in both variants). 

thanks. 

Comments

  • Maxim Riabichev
    Maxim Riabichev Sweden admin
    How does your connection procedure look like? Are you using Netscan?

    Maxim Riabichev
    PC Software Support Engineer
  • jakobhoerbst
    jakobhoerbst Vienna
    yes. tbh., I followed the example code that I even found online from you. And at this point also a big thanks for your materials (YouTube etc.), they helped me a lot!

    What surprised me a little: I have found when researching very often that the PC SDK is discontinued with OmniCore. Can it be related to this? 
  • Maxim Riabichev
    Maxim Riabichev Sweden admin
    You are most welcome! I'm glad to hear that my examples helped someone out there :)

    I'm not sure if I understand you correctly, but PC SDK has not been discontinued for use with OmniCore controllers.
    Perhaps you mean that your PC SDK app is often being disconnected from an OmniCore controller? That issue would have to be investigated in that case. Are you using the latest PC SDK release?

    Maxim Riabichev
    PC Software Support Engineer
  • jakobhoerbst
    jakobhoerbst Vienna
    I found in a presentation on OmniCore "PC SDK phased out. Replaced with 3122-1 Robot Web Services". 
    And no, I don't get any connection to the controller over the WAN port at all.
  • Maxim Riabichev
    Maxim Riabichev Sweden admin
    That information is incorrect. No such decision has been made as far as I am aware, and I work closely with the developers of PC SDK.

    Maxim Riabichev
    PC Software Support Engineer