How to send a num value to a connected Profinet device?

Hello,

I've connected an ACSI Motor from Tolomatics via Profinet to my IRC5. I configured the motor via IO Configurator in RS. It seems to work, at least the device shows as online and reachable as shown in fig. 1.



The Signal Editor says that all the IOs from the motor are digital IOs, as seen in fig 2.



 So I configured a sample signal for current motor pos and tried to read the value in rapid. That works but of course I only get 0 and 1 as readings. What do I need to do to send  the value 25.3 to a digital input of the motor? For example the motor expects a float32 as the desired velocity (https://www.tolomatic.com/info-center/resource-details/resourceid/900).

Is it even possible to read/write values from/to Profinet devices connected to the IRC5?

Answers

  • lemster68
    lemster68 United States ✭✭✭
    Is the motor capable of reading a group of signals?
    Lee Justice
  • Luzifer_
    Luzifer_ Aalen, Germany
    That's a good question. I tried to change the signal to a Group Digital output which seemed to work, but I did not transfer any data. How can I figure out that my motor is capable of?
  • lemster68
    lemster68 United States ✭✭✭
    Now that I think about it, you probably are communicating with a drive controller, which in turn, actually controls the motor.  Is that a correct assessment?  If so, then the answer lies in the documentation for the drive controller.  Otherwise, the documentation for the motor.
    Lee Justice
  • Luzifer_
    Luzifer_ Aalen, Germany
    Yes you are right. I just forgot about that, because the drive controller is mounted on the motor, so technically the communication is IRC5 <--> drive controller <--> Motor. I'm in contact with the manufacturer and will send updates if we figure anything out. The manuals only describe how to communicate via PLC, unfortunately.
Sign In or Register to comment.