how to change calibrated position on axis 1

Hi, we have an IRB 5500 robot. Its set in a B configuration, so Axis 1 angled to the left. "A" configuration would angle it to the right. I need a midway point so its sits square to the wall its mounted on. There is 95 degrees travel allowed from the calibration point either side.

We can jog axis 1 to a midway point and update rev counter and that gives us the required movements.
How can I replicate that in RobotStudio though?

or.... can I increase the degrees of travel allowed away from the calibration point

Thanks in anticipation...

Comments

  • lemster68
    lemster68 United States ✭✭✭
    Option one, fine calibrate in the midway position.  That will make that position zero degrees.  Make sure that you take note of the new calibration offset for that axis and that you make a new, clearly defined marker for where to update rev counters.  Option two, change the axis limits in the control panel, motion topic.  Make sure that it will not hit a hard stop or pull/damage any cables.
    Lee Justice
  • Grahammy
    Grahammy Uk
    Thank you for the quick response!

    Where exactly will I find option two please?
  • lemster68
    lemster68 United States ✭✭✭
    IRC5?
    Lee Justice
  • Grahammy
    Grahammy Uk
    Its IRC5P.
    The original Axis 1 upper joint bound was 1.65806.
    We increased it to 3 and got more travel, the 5500 arm rotates around to 112.5 degrees instead of the original 95 degrees, but no further. Increasing the value doesn't help.
    In RobotStudio, a value of 3 works perfectly and it rotates all the way to just short of the physical bump travel stop.

    Is there another maximum travel setting/parameter anywhere?
    The Parameter manual states the allowed value goes up 1,256,637 radians, I don't know what my original bound joint figures are measured in. 1.6 is a long way from 1.2 million!


  • lemster68
    lemster68 United States ✭✭✭
    There is an upper joint max bound parameter and lower max bound.  pi is equal to 180 degrees.
    Lee Justice
  • Grahammy
    Grahammy Uk
    thank you Lee.
    I discovered I could set the upper joint bound in the configuration of RobotStudio, but the upper_joint_bound_max had to be edited in the MOC file.
    Got there in the end
Sign In or Register to comment.