Module line is erased after change through GUI

eMDeSK
eMDeSK Slovakia
Hello all.

I work in shoe production with roughing robot. (IRB 2600 12/1.65 - TypeB RobotWare 6.01.1010)

In some cases, we put "WaitTime 15.0;" in start of the process to hold the robot in position for some time. But if we change any position of roughing point through GUI (GRC), the "WaitTime" line will be erased.
The same will happen, when inside roughing process is inserted interuption with lines:
   SetAO aoSpeedMot, 0;
   SetAO aoPressure, 0;
to stop roughing tool rotating in his path to skip some length.
We adjust roughing points many times in a day during production.
Does anybody know, where should be the problem, or is there any other way to keep robot in position of roughing proccess for few seconds?

Examle module:

%%%
  VERSION:1
  LANGUAGE:ENGLISH
%%%

MODULE M3442


 PROC P3442()
 Waittime 15.0;
  MoveL [[141.3143,-35.3899,-32.983],[0.56522124,0.01703488,0.05412972,-0.82298526],[0,0,0,0],[9E+09,9E+09,9E+09,9E+09,9E+09,9E+09]],vRough\V:=120,zRough\Z:=5,tRough1st\WObj:=obvariable;
.
.
.  
  MoveL [[111.44,98.31,-46.20],[0.063724,0.13074,-0.025756,0.989031],[-1,0,0,0],[9E+09,9E+09,9E+09,9E+09,9E+09,9E+09]],vRough\V:=120,zRough\Z:=5,tRough1st\WObj:=obvariable;
  WaitTime 0.5;
  SetAO aoSpeedMot, 0;
  SetAO aoPressure, 0;
MoveL [[113.12,104.54,-44.49],[0.06466315,0.17528014,-0.05625504,0.98078077],[0,-1,3,0],[9E+09,9E+09,9E+09,9E+09,9E+09,9E+09]],vRough\V:=120,zRough\Z:=5,tRough1st\WObj:=obvariable;

It looks lite its reverting the changes.

Thank you in advance.

Comments

  • Have you tried using the \InPos argument? Like so:

    WaitTime\InPos 15;
  • eMDeSK
    eMDeSK Slovakia
    edited July 2021
    Hi xerim and thanks for reply.

    Yes i did. But the situation is the same.
    Problem is not in instruction. It works.

    The problem is that after changing position of any point through GRC (Graphical Robot Control),
    the line with Waittime will be erased OR it will revert to previous state.

    Here is the program original program with waittime.
    Then I changed instruction to WaitTime\Inpos 2.0 and tested and it worked. On photo is  captured 18secs, but I changed it to 2.0 before run.
    Then I changed point position through GRC and tried to run it again.
    The program revert to previous state and thats the problem and I dont know WHY.  :/ 


    Thanks for any other help.


  • I have never used GRC before, but it seems like the issue lies in there. Perhaps you could modify the points the traditional way with "modify position" to get around this. 
  • eMDeSK
    eMDeSK Slovakia
    This is not practical. Points position are correcting while robot is running. We can't stop robot hundred times through shift to change line through program editor. :neutral:
    No one knows where should be the problem?


    Where does robot store backup of modules?

    Here are modules, which are currently used?
    ...\1701376_1_Backup_20200724\RAPID\TASK1\PROGMOD\
    What's here? backed up module?
    ...\1701376_1_Backup_20200724\HOME\Undo\

    What will happen, when I delete all files from undo folder?
    Will it automatically create backup from PROGMOD files?

    I think that this is only way I can workaround this situation. :-/


  • lemster68
    lemster68 United States ✭✭✭
    If your points were declared robtargets you could use Hotedit while it remains running.  No need to stop the program.
    Lee Justice