Robot studio simulation is far off

K8ie8
K8ie8 Washington
Good day all.

I have created a station from a back up and am trying to run a simulation of one of our current programs but it seems the positions are way off. When I offset the positioner to start the weld at the right place it will only be that weld that works and the rest of the program is still way off. 

Any one had this issue before? Where can I see the frame data to make sure the robot and the positioners are in the right locations?


Comments

  • JHID
    JHID USA
    Baseframes & Taskframes are the same in the controller and in the station? If not sync to station.
    If this is station existed before your backup make sure you sync over you wobj, targets, & tooldata to station

  • K8ie8
    K8ie8 Washington
    I did sync to station and still no difference. I created the station from a backup. 
  • JHID
    JHID USA
    Your wobjdata, usually stored in robdata.sys, does it have values in the u-frame or o-frame.

    If I recall correctly sometimes this moves your wobj in real-world but the difference wont be present visually in studio.

    What do you mean you did sync from station to controller, did you do this using by right licking on the robot controller in Home > Paths&Targets> Righ-Click> Motion Config > elect Robot, then selecting controller values as in picture attached? 

  • K8ie8
    K8ie8 Washington
    I cannot find robdata.sys

    Yes I did update to controller values that way, still the same thing.

  • lemster68
    lemster68 United States ✭✭✭
    Robdata.sys is probably standard for where JHID works.  It will be declared in one of your modules.  Can be in sys or mod type modules.
    Lee Justice
  • K8ie8
    K8ie8 Washington
    I figured that was a possibility. This is what I have found in the MOC.cfg
  • lemster68
    lemster68 United States ✭✭✭
    It won't be in the configuration files, *.cfg
    Lee Justice
  • graemepaulin
    graemepaulin New Zealand ✭✭✭
    You are looking for where the workobject you use for the positioner has been declared in the program.
  • JHID
    JHID USA
    K8ie8 in your path, what workobject is being used in the instruction?
    Right-click it and look at it's defintion. If you are not using wobj0, it will take you to where the wobj is defined. 

    If you are using wobj0 then having o-frame & u-frame is not the problem, since wobj0 cant have those values assigned.

    Suggest double-checking your baseframe & taskframe are same in controller, Virtual Controller, &  in station. 
  • K8ie8
    K8ie8 Washington

    I updated the base frame to what is being called out, and still no difference. I will continue to try troubleshoot this. (I am new to Robot studio, obviously)
  • K8ie8
    K8ie8 Washington
    I found my mistake. I realized when I imported my Weld gun I did not setup the tool data for the gun itself so it was using tool0. My bad. 

    Thank you all for your help. I appreciate it, I did learn from your guys help!