My simulation will not run

Hi there,

I am new to robostudio and my simulation will not run as soon as I create a virtual controller.

When I run the simulation before creating a Virtual Controller from layout, the LineMover moves the object normally but as soon as I create a Virtual Controller the object does not move and the simulation stops by itself. But I did not experience the same problem on the previous (different) PC I was using.

https://www.dropbox.com/s/zx2k14p6ja2sfnl/Solution1%20-%20RobotStudio.mp4?dl=0

Thanks.

Answers

  • Hello there,

    Can you provide a screenshot of your Simulation Setup please?

    Thanks.

    Maxim Riabichev
    PC Software Support Engineer
  • Hi Maxim,

    Thanks for replying.

    Please find attached the photos of the simulation and its errors.

    Thanks.
  • Also I would like to mention that the photos is just to show the errors. I actually want to build a system with a pick & place feature of objects from one conveyor to the other. As I have done it before when I was using robotstudio on a different machine and it was working fine, I even used the collaborative robots without issue.

    Now I am using a laptop and the new system I am trying to build is no longer working. 
    • SmartComponents are not working;
    • Robot is not moving to defined targets;
    • Etc...

    So if you could help me solve it or at least explain to me why is that happening, why it worked before and now is no longer working, I would really appreciate it.
  • lemster68
    lemster68 United States ✭✭✭
    Did you have a trial license on that other machine?  And what would the license status be on this new machine?
    Lee Justice
  • Yes I did have a trial licence on the previous machine and I am using trial on this new one.
  • lemster68
    lemster68 United States ✭✭✭
    And the trial has not expired?
    Lee Justice