Bullseye Robot calibration error

K8ie8
K8ie8 Washington
Good day all. 

I am trying to set up a different length weldgun on an IRB2600. I have been told this robot has always had issues with the TCP goes and no one has been able to fix it. But I would like to try. 

When I run the BEToolSetup  the tool straightening always fails and I get the following error: 



I have checked the fine calibration values and they match up to the sticker on the robot. I also checked the revolution counters. all seems to look fine. 

We are running a safety controller and the sync position is setup using the bullseye as the switch. When I run the bullseye I get an SC1 wrong sync position, which I understand why that warning would come up. I am wandering if this is perhaps what is causing the calibration to fail?
Has anyone else got their robot configured this way or would it be better for me to run a separate switch for the safety controller?
(As far as I have been told, ABB did the original configuration this way in 2013)

I have also tried to define the tool by teaching the 4 points and the z elongator - After doing this when I rotate the torch around the TCP it moves off the reference pointer by at least 15mm.

Thanks in advance.

Comments

  • One thing leaps to mind; Even though the control and manipulator values match the robot may not have been correctly calibrated by the ABB factory. You may wish to consider having the system calibrated by a technician.

     
  • Knud E Lindberg
    Knud E Lindberg Denmark ✭✭

    Move all axis to zero and Check revolution counters. 
    Is robot on marks ?

     



    Regards
    Knud Erik Lindberg
    Jorgensen Engineering
  • matti
    matti Germany
    Is there a n*360° issue on that robot type too as on 1600 or 140?
    (when making a revolution counter update on these with axis 4 turned 360° from normal position, you will get a valid update, but the tcp will not go on a straight line anymore - you have to try an update 360° plus/minus from your current position)