RobotStudio event

IRB6400 S4C controller Error 03:07003 Unexpected interrupt on MC

Hello all,

I recently bought an ABB IRB6400 and while doing a cold start on the S4C controller I get the error "Error 03:07003 Unexpected interrupt on MC". It does this every time I try to cold start the controller and I can't get past it. 

Could an inpropper shutdown of the controller be the cause of this error? I think there is still a robotware os version on the controller, 1 backup battery was dead, the other one had a low voltage warning, i measured 3.6 volt on that one.

Would a fresh install of the robotware/baseware OS be a possible sollution? I currently only have the baseware OS 2.1 files on my PC (no floppy disks) and I'm waiting for the USB floppy disk emulator to arrive. So i can't yet try to install the baseware.

Any advise on this error will be greatly appreciated.
Thanks in advance.


  • If it is failing to boot you have nothing to loose if you disconnect both batteries with the power off (leave disconnected of 10 minutes or more).
    This will clear out the memory.
    The controller will then cold start when powered on and it will go through an extended self test routine.
    If it passes those tests it will ask for the first boot disk - if it fails a test then we will have to dig a little deeper to find the cause.
  • Thank you very much for your reply graemepaulin. I will give this a try when i get back home today and I'll keep you updated.
  • Hello graemepaulin, I disconnected both batteries, the robot and the power plug for 30 minutes and afterwards plugged everything back in. The controller did a cold start but I get the same error message as before: "Error 03:07003 Unexpected interrupt on MC".
  • Checking on this error again shows the error is with the main computer board.
    One of the following could be the cause:
    1) RAM not fully cleared which you have dealt with by disconnecting batteries for more than 10 minutes with the power off.
    2) the robot computer has had a non compatible Baseware installed - probably not the case here?
    3) the main computer board has a fault and needs to be replaced.

    Only certain combinations of boards are compatible, so best to replace like with like.

  • I'm not sure but there's a possibility the previous owner tried to reinstall the baseware. I have a few questions.

    -What is the latest baseware version that can be installed on the S4C controller?
    -If a non compatible baseware has been installed on the controller, does this mean the main computer board is lost, or is there a way to reinstall the correct Baseware?
    -Would the robot controller also have to be replaced if a non compatible baseware has been installed on the controller?

    What are your recommendations.

    Already thank you very much for your help and time.
  • You would have to share what boards you have installed that will determine what Baseware you can install.

    From the previous support cases you would need to know what version of Baseware has been installed then you have to get hold of the correct main computer board to boot the system.
    Once booted there is a procedure to redo the Baseware to suit the hardware you want to use (the Robot Computer board is apparently the issue here you have to boot the system to be able to re-flash it with the correct Baseware....)

    Can you borrow a main computer to see if this is the issue?
  • The boards currently installed are:
    -DSQC 373
    -DSQC 323
    -DSQC 361

    The configuration list of the robot states the version of robotware is "Baseware OS plus 3.1".

    The files the previous owner gave me are Baseware OS 2.1 But he wasn't sure if these were the files for this specific controller and robot. So I think he might've tried installing a baseware OS 2.1 on a system which previously had a baseware OS plus 3.1 installed?

    So your suggestion is to try and get a hold of a main computer with baseware OS 3.1 installed on it, this way i would be able to boot the controller?

    I don't think I'll be able to borrow a main computer with the correct baseware installed. If I were to buy a new (used) main computer board, would it be possible to boot and possibly reinstall the baseware?

    Thanks in advance.
  • You can run 3.1 or 3.2 with this hardware.

    From what I have read it is the robot computer that gets flashed with the data from the previously loaded Baseware and looks for the appropriate main computer - you get this error if it can not find it (one of the causes of the error).
    I do not think the robot computer would accept Baseware 2.1...
    So if you can borrow a 361 main computer to see if the system boots through to loading the Baseware it will prove that the 361 board is faulty.

  • Ok, I'll see if I can find another 361 main computer. I'll keep you upadated. Thanks a lot for the help already!
  • The 361 main computer arrived today. I tested it out and unfortunately got the same error.

    I saw in a similar discussion someone who had the same error and he had to change the robot computer (373). I pulled all the cards out again to inspect them more closely and saw someone had tried to re-solder some resistors on the memory board (323). 
    So i either have to order a new robot computer (373) or a new memory board (323). 50/50 chance but I'm bad at gambling so I ordered both of them. 

    Hope a completely new (used) board set (361, 373, 323) will solve the problem.

    I also took a thermal image of the memory board (323) but didn't see any specific heat spots, no IC's, resistors or any other components that got significant hotter than the rest, not even the ones that were (poorly) re-soldered.

    The memory board (323) pulled around 0.702 amps with a total power consumption of 3.4W.
  • The new robot computer board (373) and memory board (323) arrived on monday. I installed them both and the S4C controller booted right up to the screen asking for a key disk. I was able to install the robotware 3.1 first try and the robot was able to move! I had to re-calibrate/ update the rev counters to be able to make linear movments but this didn't take to long. Thank you for the help!

  • Great news & thanks for the update, always good to know what fixed the issue.