Invalid data for component rot!

I often record points with the correct tool, coordinate system selected.  But when I want manually adjust a point, and attempt to edit the data, I will get [MyPointName] Invalid data for component rot.

I suspect this has something to do with the rotation of my tool when the work object was created, but I am stuck as to what to look for.

Answers

  • lemster68
    lemster68 ✭✭✭
    Quaternions must be normalized.  The sum of the components' square roots must equal 1.  Or be very, very near it.  There is a function to Normalize a rotation.  If you are not too totally out of whack, it may help you.
    Lee Justice
  • I will look into the function, just wondering when I teach / modify a point why it doesn't record the correct values in the first place.
  • DenisFR
    DenisFR ✭✭✭
    Hello,
    I've made a little software to help you with orientation:
    Look at Reorientation Tab.

  • mrva
    mrva
    edited May 23
    Hi, I have the same issue with a great difference that the target has a rotation [1,0,0,0], thus perfectly normalized but I still get the error message when I hit the OK button in Program data edit window - invalid data for component rot. Does anybody experience the same issue?

    RobotWare 6.15.01

    Edit: I just tried an empty robot, added one robtarget with [1,0,0,0] orientation and still I can't edit the target using the Program data editor.
  • SEIL
    SEIL
    We also got this issue/bug on RobotWare 6.15.01
    After updating to 6.15.02 the issue was solved