RobotStudio event

Suddenly unable to connect to the virtual controller

Hello everybody,

I am fairly new with RobotStudio. As the title suggests I was working on a virtual controller updating some modules then the controller turned "unreacheable". I was thinking that I was experiencing some failures since the compilling was finding a lot of unresolved issues or maybe I was asking too much computation for some reasons.

However, I saved my open files and restarted the station. Since then, the controller hasn't been available anymore. The error was: 

RobotStudio .NET exception: C0040403 : No response from controller.
Netscan timeout
Base exception: RobApiException
C0040403 : No response from controller.
Netscan timeout

I thought Ok i 've messed up with something, let's restart from the scratch. I took the backup from the real controller, created and empty station with a virtual controller based on that backup (which is from a robot brand new so no modifications from the shipment and no modifications from the first virtual controller based on that backup) and waited. The error continued to pop Up.

The version of RobotStudio is the last available 2022.3.2, the robotware from the robot is 6.15.01 with the the FlexPendantSxTPU4Software 1.1.1. The robot is IRB 660-180/3.15.

Reading around I thought It could be a problem with the firewall. I am quite sure that my computer has done some windows updating close, really close, to this event. 

I would like to stress the point that it was working and then stopped. Even restarting from the scratch hasn't solved the problem. The error is still the same.

Every suggestion is well accepted.

Thank you

Gian Maria


  • Maxim Riabichev
    edited April 2023
    Hello Gian Maria,

    Please verify that there isn't some network security software closing down the Virtual Controller process and/or blocking communication to/from it.

    Whenever you have a virtual controller started, then you should have a process called ABB Virtual RobotController (32bit) in your Task Manager. If this process is not accessible by RobotStuio for whatever reason, you might get this kind of exception that you mentioned.

    If you need additional support with this, please reach out to your local ABB:

    Best regards,
    Post edited by Maxim Riabichev on

    Maxim Riabichev
    PC Software Support Engineer
  • Gasparri
    Thank you for the fast support!
    I started to check the firewall rules then something striked me and I've noticed that the computer was slower than usual. In poor words I've discovered that a malware had compromised the robotware 16.5.1 and 16.5.2. With the IT guy we've blocked the malware and deleted the robotware. It wasn't easy at all due to the file system permissions. Once removed the station and its virtual controller have restarted properly.

    I am reporting this for whom could experience similar problems.