Cannot Import Geometry

DanS
DanS ✭✭

I've been having a problem when trying to import geometry.  It will stall at 51% with the CPU at full load and after about 15minutes will present a Failed to Import Geometry Error.

The strange thing is it only seems to do this on one computer.  Our other RS machines do not display this error.

Anyone heard of this?

Comments

  • DanS
    DanS ✭✭

    It seems I cannot import geometry (SAT files) that were at one point imported into RS.  So something has happened to my ability to import SAT files between now and then.

    I've tried uninstalling/reinstalling...no luck.  Is there something the uninstall misses?

    I can import the geometry on another RS machine and save as library.  I can then import this library to RS on the broken machine and all is well.

    DanS2007-6-13 15:39:55
  • DanS
    DanS ✭✭

    I've recently upgraded to RS5.09 and install RS5.09 SP1, and can still not import geometry (same symptoms as above).

    Does anyone have any ideas?  This is bringing all work to a standstill.

    Thank you very much.

  • bhanscom
    bhanscom United States

    DanS,

    Have you tried to save out a SAT file in an older version.  RS509 uses SAT version 17(default). 

    Although I have not seen the problem you are having, I have noticed a couple of other rather odd peculiarities associated with importing and saving geometry in SAT v17.  In order to correct them, I have had to save in v15 instead.  Not sure what exactly is going on, but it sometimes seem to solve issues.

    Brian

  • DanS
    DanS ✭✭

    Hello,

    Thank you for the reply.  Unfortunately I've exported from SolidWorks 2007 w several different SAT file versions to no avail.

    I can import any sat files into the HOOPS 3d viewer just fine.  But Robotstudio refused to bring anything in.  What kills me is the fact that I've imported these SAT files in the past.

    Another observation:  when my PC is trying to load geometry is goes very slow during the load and finally stalls.  On another RS machine the geometry loads in less than a second.

  • Hi dan

    There is also the possibility to try and import the sat file in and empty station and then save the satfile as a library file. then afterwards you can import the library file to the station.

    I have done this many times when RS wont import into the station,and it works for me:)

    Kent Zibrandtsen
    Dept manager robot welding
    [email protected]