PC SDK app getting a certificate validation error

Options
I am getting this System.Exeption error when I open my pc sdk app. The app works perfectly with a virtual controller.

System.Exception: Exception of type 'System.Exception' was thrown.
 ---> RobotStudio.Services.RobApi.RobApiException: FAFA0004 : ROBAPI_E_TRUSTFAILURE
Server security certificate was invalid and no callback was specified.

Anybody have an idea how to fix this without bypassing the need for a certificate validation?

Answers

  • leonardodo
    Options
    We're having the same issue with our IR14050 robot. Did anybody solve this problem? 
  • hassanm
    Options
    I have tried creating new certificates and uploading them to the robot, adding the certificate to the Trusted Root Certification Authorities on the PC and still no luck. 

    For now, the way I am getting around the issue is to use this line to connect to the robot:

    robotController = Controller.Connect(controllerInfo, ConnectionType.Standalone, false);

    This bypasses the need for certificate validation. 

    After using this, I found I was not able to start or stop the RAPID program from my PC SDK app, even when logged in as an Admin.

    After lots of probing, I found Roles under Edit User Accounts in RobotStudio. Under the Administrator Role, I found the "Remote Start and Stop in Auto" was deselected by default. I gave the Admin account the grant and was then able to use my PC SDK app to control the robot as expected.

    I am still waiting on support to help me figure out why the certificate validation issue is occurring as once we start production, I would like to have the certificate validation in place for added safety.
  • Maxim Riabichev
    Options
    Hello there,

    Currently there doesn't seem to be a way to handle certificates via PC SDK.

    We're looking into a solution to this issue.

    Maxim Riabichev
    PC Software Support Engineer