URGENT: ABB Robot Controller Error - Unable to Access Teach Pendant Menus or Reset System

Options
Hello everyone:
I'm currently facing a critical issue with an ABB robot where the teach pendant keeps displaying an error menu. Every time I acknowledge the error by clicking confirm, it just reappears, preventing me from accessing any of the teach pendant's menus.
I've managed to connect to the robot through RobotStudio and can see that the robot's system is in a fault state. However, I do not have write permissions within the software, which means I am unable to reset the system or enter the boot menu. The controller is running on version 7.X.
With the system being version 6.0, in the event of a system fault, it would default to having write permissions, but this is not the case with 7.X. I am looking for a way to reset the system or enter the boot menu when the teach pendant is inoperable and RobotStudio lacks write permissions.
Any advice or guidance on how to resolve this would be greatly appreciated. Thank you in advance for your help!
Tagged:

Best Answer

  • Tompanhuhu
    Tompanhuhu ✭✭
    edited May 19 Answer ✓
    Options
    You can restore a snapshot or the whole system to default from RobotWare Installation Utilities.

    Follow these steps if robotstudio / flexpendant is not working.

    Forcing startup of the RobotWare Installation Utilities mode
    Repeat the following action two times in a row:
    1 Turn on the main power switch.
    2 Wait for approximately 15 seconds. Note The Computer LED should be in flashing red state.
    3 Turn off the main power switch.

    The installed system is de-selected and in the next startup, the RobotWare Installation Utilities mode is started. This has no effect if the controller is already in RobotWare Installation Utilities mode.

    You can read more about this in Product manual - OmniCore **** (E10/C30/**)


    Systemintegrator - Web / C# / Rapid / Robotstudio

    If I helped, please press Vote Up  :smile: