Can't create virtual controller

Options
Mikael_Olofsson
edited July 4 in RobotStudio
Hi,
I have been having this problem for quite some time now. I can not create a virtual controller with RobotWare 6. However RobotWare 7 works fine.

No error messages or anything. RobotStudio just quit. The last message I get before RS shuts down is (sorry for the french) : 
  Création du système de commande virtuel.

I can open old projects just fine.

I'm currently running
  Windows 10 PRO
and
  RobotStudio 2023.3 (64 bits)
  Version 23.3.10550.0
But I have been having this problem since several updates of RS.

Several months have passed since I first requested help from support but they have been ghosting me.

One particularity of my computer is that I'm not admin on it. Company policy Dilbert style...

Post edited by Mikael_Olofsson on

Comments

  • Maxim Riabichev
    Options
    @Mikael_Olofsson
    I suspect that this is caused by security software running on the PC preventing InstallationManager.exe to launch.

    Please verify that you are able to launch C:\Program Files (x86)\ABB\RobotStudio 2024\Bin\InstallationManager.exe and/or get in touch with an Admin to grant permissions for Installation Manager.exe to be launched.

    OmniCore (RW7) uses InstallationManager7.exe which does not seem to be blocked on your PC.

    Maxim Riabichev
    PC Software Support Engineer
  • Mikael_Olofsson
    Options
    Thank you @Maxim Riabichev, I believe you are right.
    I'm waiting for feed-back from our IT people.

    I tried to start them separately and the InstallationManager7.exe worked fine. InstallationManager.exe shut down while loading the existing virtual controlers. So I removed them and now I can start the InstallationManager.exe. However, it shuts down when I try to create a new virtual controller. But before doing so, I get a message in a pop-up (sorry for the french).

      Appliquer les modifications
      L'installation mettra à jour le systeème de commandes avec vos
      sélections et installera le(s) produit(s) / licence(s).


      Souhaitez-vous continuer?


  • Mikael_Olofsson
    Options
    Problem solved. It was indeed our security software that messed things up.
    Thanks for the help
  • Maxim Riabichev
    Options
    Happy to hear that the problem has been solved!

    Maxim Riabichev
    PC Software Support Engineer