RW 5.09 and RobAPI

Just created a system in RobotStudio from backup, of a real configuration (IRB2400 attached to XYZ external axis). The real system uses RW 5.09.0166. When I try to start the VC in RobotStudio, I get following message:

"There was a problem when connecting to the controller

A new RobAPI needs to be installed since the current version is not tested against this Robotware version failed, hr=c0040414

The Robotware version is later than the installed API"

RW 5.09 manual says that RW CD should give the option to install the latest .NET framework but I don't get this option when installing the RW....

where can I get this new RobAPI?



Comments

  • PerSvensson
    PerSvensson Sweden ✭✭✭
    Hi
    If you take the RobotWare CD delivered with the robot and just install the RobotWare located on that cd onto your RS pc.
    Per Svensson
    Robotics and Vision Specialist
    Consat Engineering
  • neil
    neil Norway
    I have uninstalled and re-installed RW 5.09.0166 from the CD that was delivered with the robot, and there was still no option to install latest .NET framework.....The virtual controller still fails to start though. The error report files are attached


    2007-08-07_111328_WER58d4.dir00.zip
  • neil
    neil Norway
    here is a backup of the system I am trying to start up


    2007-08-07_111730_Backup_20070806_3_Bewegungstask.zip
  • Anders S
    Anders S Sweden mod

    Hi Neil,

    Your backup use the additional option (mediapool) "STANDALONE003". If you not selected a complete installation of RS 5.09 was this mediapool not installed.

    But you can install it separate from the RW CD. The installation is placed under "Additional OptionsStandaloneController" on the CD.

    Best regards,
    Anders Spaak
    ABB Robotics
  • neil
    neil Norway
    I have the "STANDALONE003" option already installed, the initial problem was with the RobAPI and the latest version of the .NET framework, which was not available on the RW CD...
  • Anders S
    Anders S Sweden mod
    What version of RobotStudio are you using?
    Best regards,
    Anders Spaak
    ABB Robotics
  • neil
    neil Norway
    I'm using Version 5.08
  • Anders S
    Anders S Sweden mod

    Ok, that's why you have problem. The RobAPI that comes with RS 5.08 is not compatible
    with RW 5.09.

    But if you install RobotStudio Online 5.09 which is included on the RW 5.09 CD it should work, because then will the new RobAPI be installed.

    Best regards,
    Anders Spaak
    ABB Robotics
  • neil
    neil Norway
    Thanks for your help Anders, I have installed Version 5.09 and I no longer get this error,

    Regards,
    Neil