Importing Large CAD data into RS4.0

We are having trouble importing a car body in IGES format into RS4.0.

Car body is in IGES format (total  file size = 255 MB)

We tried to import directly IGES file into RS 4.0

It took almost 3 hours to import into RS4.0

Then we tried to save the workcell as well as save it as a library (.jt file format).

But the error was "Cell cannot be saved .. out of memory"

Then we tried to use another CAD software (Solidedge) and converted from IGES into JT file. This JT file is visible in Solidedge viewer.

But, when we tried to import this JT file into RS4.0, the car body is not visible (nothing...no errors).

 

please suggest how to do this.image

 

Comments

  • AndersJAndersJ Sweden mod

    Hi,

    Around a maximum of 100MB is the recommended size of geometry files when working in RS4, but of course this is depending of your hardware performance as well.

    The reason why the JT file is invisible in RS is probably because it's a newer version then what's supported in RS4.

    Best regards,

    Anders Jahnberg, ABB Robotics

    Best regards,
    Anders Jahnberg
    ABB Robotics
  • edwinderryedwinderry United Kingdom ✭✭

    Hi,

    We had the same problems with geometry for a complete car body.

    We found a successful solution by using Deep Exploration by Right Hemisphere to convert 732Mb of STEP data to VRML which we then converted to JT using the RobotStudio CAD Converter.

    In this way we imported a total of 120Mb (large saloon car) into RS in approx 1 hour. The PC we used had 4Gb of RAM and a 64Mb GeForce video card.

    I hope this helps.

  • Thanks. We achieved the result as follows:

    Imported the car body IGES file into Pro-E.

    Inside Pro-E, we converted IGES into STL format (Stereo Lithography).

    We took the STL inside the RS4.0 CAD Converter and converted from STL into JT format.

    the result was that the IGES file of 310MB was converted into 12 MB, without loss of details. Only thing is that you cannot select entities easily in JT file.

     

  • UnitedpeopleUnitedpeople SW
    edited August 2020
    I don't know, maybe I should have created a new thread in the forum, but I have almost the same problem.
    I imported STL file (total file sixe is 75.31Mb, this one) into RS CAD Converter and converted it into .jt extension. But when I tried to import this .jt file to RS, the 3d model was invisible. What version should I have?

  • Simranto09Simranto09 ludhiana
    Thank you for all your help

Sign In or Register to comment.