Hide application in ABB menu

Options
I do not wish my ScreenMaker application to appear in the FlexPendant ABB menu.
Instead the screen must be displayed by my Rapid program using 'UIShow'.

I have tried using a blank icon and a blank caption in Project Properties, but if I click on the white space in the ABB menu the screen is displayed.

Is there a way to exclude the application from the ABB menu using ScreenMaker?

Thanks,

Kevin

Comments

  • carlosmtz2000
    Options

    Hi ...

    Try to remove the file: TpsApp*.gtpu.dll and try to UIShow RAPID instruction.

     

    Never try this my self, but it should work ..

     

    BR
    Carlos Martinez
    ABB
  • Kevin
    Kevin ✭✭
    Options

    Hi Carlos,

    I deleted my TpsApp*.gtpu.dll file from the VC then warm-started and launched the VFP.

    The application was not in the ABB menu, as expected, but UIShow caused an execution error because TpsApp*.gtpu.dll was not found.

    Could I leave TpsApp*.gtpu.dll in place, but manually edit it to prevent it showing in the menu?

    Any other ideas?

    Thanks,

    Kevin

  • carlosmtz2000
    Options

    You are right .. you are trying to launch the screen from that dll .. try this ..

    (1) This is your RAPID code: 

     

    UIShow "ViewTest_Screens.gtpu.dll", "ABB.Robotics.SDK.Views.MainScreen";

     


    (2) Rename the file "TpsViewTest_Screens.gtpu.dll" to "ViewTest_Screens.gtpu.dll"

     

    This should work ...

     
    Carlos Martinez
    ABB
  • Kevin
    Kevin ✭✭
    Options
    Hi Carlos,

    That works OK.

    Thanks a lot.

    Kevin