Interlink is missing digital signals ? [WebWare SDK]



I'm having a problem with my app losing pulses from robot

I wrote the folowing code in VB.NET 2003

Private Sub AxHelper1_IOChanged(ByVal sender As Object, ByVal e As AxRimbaseLib._DHelperEvents_IOChangedEvent) Handles AxHelper1.IOChanged
contador += 1
Label1.Text = contador
End Sub

I have a form with an abbPilot, a label and a helper

Then I execute the folowing routine in the robot in a multitasking

  PERS num reg1:=24;
  PERS BOOL bMsgSoldaRec :=False;

  PROC Main()
    VAR bool FimEspera:=FALSE;

    WaitDI weld_ready1 ,1;
    IF weld_error=0 THEN
      SetDO doWeldOK,1;
      Incr reg1;
      TPWrite "ON " Num:=reg1;

      WaitDO close_tip1,0;
    WaitDO close_tip1,1;
    SetDO doSoldaOK,0;
    TPWrite "OFF";

Then in the main task 24 spotL instructions are executed.

In the teach pendant I see 24 "ON's and 24 OFF's always

I should then have the VB counter set to 49 (1 initial scan + 24 ON's + 24 OFF's )

The fact is thar every time I run the robot I see a different count varying from 44 to 49

The signal remains ON for 1.5 sec and off for 2.5 sec in average. The interlink is configured to 200ms pool rate.

I can't understant what's going on.

I tested it whit webware SDK 4.0, interlink 4.0 and

I ran the application in a Win2K sp4 and in a XP sp2 machines. The result was the same. Except that in Win2000 I have frequent interlink Crashes even if is alone wiht no application acessing it. In XP is stable until now...

Robot is a m2000 RW 4.0 rev 113


Giulio S.