Flexpendant startup problem

I am trying to use the new ScrennMaker 5.12 CTP.

I have install all the last version. I'm using the robotstudio 5.12.02

When I start my Flexpendant I have a startup problem.

I try to make an application with VB as well and I didn't get any issue at this time with the new version.



  • Ensure that your system has the option "FlexPendant Interface". This is required to run applications created with ScreenMaker.
    Henrik Berlin
  • I Try with an other system with FlexPendant Interface option and it works.

    If I want to make some test Offline and if I don't have this option yet. Can I select this option or get a virtual key for this option?

  • Yes, you can test this offline and that is one of the intended ways of working with ScreenMaker and RobotStudio.  You will need to add the Flex Pendant Interface option to an existing virtual controller system or create a new virtual controller system using the System Builder in the Online or Offline tab.    Once that is done, you can start up the virtual controller, build and deploy and then launch the Virtual FlexPendant.


  • Hello dear colleauges

    Please, help me if you can. I made everything as it`s described above, but still not ok. The error message still appears and I checked the modulis in the system info and there is no FlexP Interface on the list. I restarted as many times and types as I could and still nothing. Can someone help me???
    I made a new system, choosed 617 Flex P Interface, restarted I-Start, and with P-Start and so one, created a new screen maker project, 2 windows, connected to virtual drive, Build it, and deployed. Build was successfull and the deploying also, the error still remains.

    Any ideas, I really need to work with screen maker.

    Thank for all of you.

    Regards Szily
  • Hello,

    Can you provide the backup of the system and attach it to the forum.
    This shall help us understanding the system better.

    Abhishek PM
  • webwiz/5071/IRB140_5kg_0.81m_4_BACKUP_2012-07-05.rar

    Dear All!

    Here is a backup of my system, now I started to be very nervous, I try everything and still not working. I don't know what to do, I can't be so stupid.

    Please help me! I have a project that must be finished till middle of July. This stopped me totally. 

    Thanks in advance.

    Have a nice day
    Regards Szily

  • The option FP interface was missing. See the attached document how to add it. I have also added an rspag-file with the modified system.

    Word document that describes how to add the option.

    Here is the .rspag-file (unzip it first)

    Henrik Berlin
  • Dear Henrik Berlin!

    I can`t say you so many thanks as I`d like.  IT`S WORKING!image
    Thank you very-very much.imageimage
    I`m wondering what was wrong with my method. Maybe I know, but I will think about it.

    I owe YOU with 1.

    I hope some day I can meet you somewhere and say thank you personally.image

    Have a nice day.
    Best regards
    Regards Szily
  • Dear Henrik Berlin
    i have same problem, i try to Add option FlexPendant Interface, but i cannot find the 617-1 inside my backup but i have it really in the controller