Unable to Connect to Virtual Controller

I have a new installation of Robot Studio and am new to the software. Problem is that I am unable to connect to the virtual controller. I have tried the demo systems and they do not connect either. The PC I am using is not connected to any robot "true offline" and I am wondering if this is part of the problem.
 

Does anyone have any suggestions as to what I need to do to fix this problem? I do have RobotWare installed, but there is still a problem that I can not connect.

Comments

  • Here is the error I get when trying to connect to the virtual controller.

     

    Any suggestions?

     

    image
  • Henrik BerlinHenrik Berlin Sweden ✭✭✭
    This may be a firewall issue. Do you have any local firewall active on you PC? If possible, try to disable it and see if it helps.
    Henrik Berlin
    ABB
  • I am on a corporate network with an external firewall. I have checked the windows local firewall and it is deactivated. Any other suggestions?
  • Henrik BerlinHenrik Berlin Sweden ✭✭✭

    Is there any other firewall software installed on your PC? (Perhaps that is why the Windows Firewall is disabled?) Within ABB for instance, we are using the McAfee software. Recently, ABB has introduced "McAfee Host Intrusion Prevention Software" for all ABB computers that basically shuts down all local communication between processes on your PC. To make RS work with the virtual and real controller for ABB people we have had to introduce exceptions to the default firewall configuration. Perhaps there is a similar setup at your company? The required exceptions are described in the Release Notes.

    Henrik Berlin
    ABB
  • Since this is a corporate computer and I do not have admin rights, there is no way to disable the firewall or change the settings in McAfee. I have looked for the release notes you mentioned to see what settings needed to be made but did not find any reference to settings to introduce exceptions to the firewall configuration. If you could provide a link to the "Release Notes" with a reference to the area you have mentioned, then perhaps I could have the administrator make the noted changes.
  • Henrik BerlinHenrik Berlin Sweden ✭✭✭
    Please see the attached extract from the RobotStudio Operating Manual 5.13 (not yet released). For 5.13 the information has been removed from the Release Notes and put into the Operating Manual. The information as such is similar to what is in the Release Notes of 5.12.03.
     

    Henrik Berlin
    ABB
  • Thanks for the tip. I had the system admin make the suggested changes and I can now connect to the virtual controller. Clap
  • aGamelinaGamelin Nampa, ID
    I tried the link <http://forums.robotstudio.com/webwiz/772/NetworkSettings.zip&gt; and got: 

    Not Found

    The resource could not be found.
    I am having the same issue with Robotstudio 2019.2 that has Partner Edition. I have a corporate computer and I do not have admin rights,
    Please Help :)

  • Maxim RiabichevMaxim Riabichev Sweden admin
    Hello,

    Could you please create a new thread explaining the issue you're having in detail, rather than reviving a 10 year old thread by saying that you're having "same issue"?

    Thanks!


    Maxim Riabichev
    PC Software Support Engineer
Sign In or Register to comment.