Module refuses to be deleted

DLcygnet
DLcygnet United States ✭✭

I didn't realize that anything named "Module" is a reserved name.

I had a Module1 created, then I wanted a second. So when it offered me the choice of a new module, I named it Module2.  But RobotStudios had problems with that Module name being "ambiguous."  So I tried to delete it and start over. It wouldn't delete. I tried to rename it. It wouldn't let me. I tried adding things to it like a main program to see if it even existed and couldn't. I've restarted Robot Studios, come back and it's still there. Several times.  Having this module there makes it impossible for me to move along paths, run other modules, or do anything that involves having the robot move on its own. The error message in the teach pendent is just as vague and won't let me do anything from there. In fact, the module doesn't exist in the teach pendent.

I'd rather not have to start a whole new station and lose a couple hundred points just because one module refuses to delete and remains in an ambiguous state.

Lisa Cardon
Saving the world from the scum of the universe.

Comments

  • Graeme
    Graeme New Zealand

    Hi Lisa

    Have you tried deleting it from program maker?

    Open this from within RobotStudio using 'edit program' under 'program' on the main menu.

    You should see the module in the tree, right click on it and select delete.

    Answer no to saving changes to task main, on exiting Program maker.

     

     

  • DLcygnet
    DLcygnet United States ✭✭

    Tried that before and there was no program... no tree...

    Ah! Found it. Darn hidden tool bar.

    Thank you. Yes, that's the problem. And apparently the Module had triplicated itself and thus wouldn't delete.

    Lisa Cardon
    Saving the world from the scum of the universe.