Virtual Serial Port Communication

Hello,

I'm attempting to simulate communications with a hardware device to RobotStudio 5.14 for design and troubleshooting purposes, and I'm attempting to use a Virtual Serial Port to do so.  The virtual serial port software I'm using is the FabulaTech Virtual Serial Port Kit.

I can use the "Write" commands in RobotStudio just fine, and receive that data just fine through the VSP, but whenever I attempt to use a "Read" command in RobotStudio, the program hangs, and cannot be stopped.  I am sure that my simulator is sending data through the VSP, because I can pick it up when I run a second instance of my simulator.

I've attempted to set very short Timeouts and enabled error handling, but no matter what I do, RS hangs on any Read command.

Whenever I use the same code with the actual controller and the actual hardware I'm attempting to emulate, it works just fine, but I'd really like to be able to simulate offline for design purposes.

Does anyone know what might be causing this error?  Has anyone else attempted to communicate with RS with a VSP before?  Is there a preferred VSP for this application?

Thanks

Comments

  • I found a solution to my own problem, for anyone else that might come across this.

    In the advanced settings of the FabulaTech Virtual Serial Port Kit, make sure the handshake setting is set to Full (should be default), but also make sure that "DTR to RI" is checked (not default).

    Now RS can communicate perfectly through the VPS.

    Thanks
  • Update:

    So after leaving my programs over the weekend, I'm returning to find the same problem reoccuring (a RS hang on "Read" commands), even though I haven't changed anything since the last time it worked.  Stepping through the program shows that it opens the COM ports just fine, and can Write without issue, but any Read command causes an indefinite hang, with no pass to error handlers, and any attempted manual stop of the program or virtual controller will cause the entire RS suite to crash.  If anyone has any ideas, that would be great, otherwise I will post again if I find the source of the problem.
  • It would be much easier to use the Virtual Serial Port Driver, since in the pro version is:
    sharing one real COM port among multiple applications at a timeand ability to merge several serial ports into a single bundle.
Sign In or Register to comment.