RobotStudio 4.0 crash issues

I'm having a problem with my RobotStudio 4.0 installation on a Dell M6400 laptop running Windows XP Pro. The program opens quickly, but as soon as I add a robot or any geometry things start running very slowly with the program hanging for tens of seconds before I can interact with it again. 

I tried starting a 140 controller and got the following error message: 

Assertation failed!
File: D:integr
el4_0.xxiofclasslibeioeio.c
Line 2036
status == OK

My D: drive is a DVD drive, which is empty.

Creating a fresh 140 controller still gives the same error.

This problem occurs for brand new stations or old stations I've used successfully in the past. 

Could there have been a recent Windows update that is interfering with RobotStudio? I haven't installed any programs recently since this behavior started.

Thanks,

Jon

Comments

  • AndersJ
    AndersJ Sweden mod
    Hi Jon,
     

    Please try to generate a new key.id on the virtual controller you want to start.

    (Setup Controller>Change Controller>Select system and click Properties>Directly click Finish in the wizard.)

    Then set current robot and try again.
    Best regards,
    Anders Jahnberg
    ABB Robotics
Sign In or Register to comment.