Information to all users of FlexPendant SDK

Niklas SkoglundNiklas Skoglund Sweden admin
edited August 2013 in Developer Tools

FlexPendant SDK enters Limited Support

The software platform in the ABB FlexPendant device is based on Windows CE 6 and .NET Compact Framework 3.5.

Compact Framework was supported by Visual Studio 2008, but unfortunately Microsoft made the decision not to support it in later versions of Visual Studio.

Because of this ABB has had to adapt and will offer FlexPendant SDK under Limited Support only, from the next major release onwards.


Switch to ScreenMaker

ABB recommends all FlexPendant SDK users to switch to using ScreenMaker instead.

ScreenMaker is a tool in RobotStudio for designing FlexPendant screens.

It lets you use a visual designer to bind screen control properties and events to RAPID variables and I/Os in the IRC5 controller.

The program logic is implemented in RAPID code. If you for some reason cannot or do not want to port your existing FlexPendant SDK applications to ScreenMaker, you can continue using FlexPendant SDK under Limited Support as long as you have VisualStudio 2008 Professional.

 


Best Regards, Niklas Skoglund
ABB Robotics

Developer Center
RobotStudio Blog
Post edited by Niklas Skoglund on

Comments

  • Is it possible to use Visual Studio 2008 with RobotStudio 5.15 to develop applications using the FlexPendant SDK? I have Visual Studio 2008 Professional and have just installed 5.15, and I don't have the option to create a new FlexPendant project (as discussed in the application manual)
  • Niklas SkoglundNiklas Skoglund Sweden admin
    Yes you can use FlexPendant SDK 5.15, which comes with the RobotStudio inastaller, and Visual Studio 2008 Professional.

    Best Regards, Niklas Skoglund
    ABB Robotics

    Developer Center
    RobotStudio Blog
  • Thanks Niklas - I'm not sure what happened, but uninstalling RobotStudio and reinstalling it then gave me the option of FlexPendant projects in VS2008. Thanks for your help!
  • labulabu France ✭✭
    Hello,

    Does that mean that we will soon have no solution to create our custom HMI's on the FlexPendant?

    Will we be able to load our HMI's developped under 5.15 SDK on the next RobotWare, what is the deadline?

    We have spent several hundreds of design hours to have a generic HMI solution customizable from Rapid and would not appreciate to have to dump it.

    Please come back with more details.

  • John WibergJohn Wiberg Sweden admin

    Hi labu,

     

    Does that mean that we will soon have no solution to create our custom HMI's on the FlexPendant?

    You can still use the FlexPendant SDK to create HMI's. We will not remove it and we will continue to support it. But since Microsoft will not provide support to us, then our ability to provide support to you will henceforth be limited if it is related to a Microsoft issue. Normally that will have no effect on what has already been developed and tested. This since the FlexPendant platform will not change.

    Will we be able to load our HMI's developped under 5.15 SDK on the next RobotWare, what is the deadline?

    Yes. The functionality that you are using will still be there, and just like before we would recommend a rebuild using a matching version of what you have in the controller.
    There is no set deadline. As I understand it the FlexPendant SDK will continue to be released with all IRC5 releases.

     

    Also see my response to a similar post over here:

    http://forums.robotstudio.com/discussion/8203/what-is-the-meaning-of-limited-support-with-the-flexpendant-sdk-with-rw-5-15#latest

Sign In or Register to comment.