axis configuration is different between Flexpendent and virtual Flexpendent

Jenny
Jenny pittsburgh
I ran my RAPID code in RobotStudio, which worked fine. However, when I put the code in the real controller and try to run it on the real robot, I got decoupled joints, where joint 4 is 200+ while joint 6 is -200. 
I checked the configuration of joint4 and joint 6 on the virtual controller of RobotStudio, both of which  were near 0.
I don't know what's going wrong and how I can fix this.

Answers

  • Henrik Berlin
    Henrik Berlin Sweden ✭✭✭

    It is recommended that you turn the robot configuration on to have full control of the motion. You can do it by using the RAPID instructions "ConfJ \On" and "ConfL \On". If not your robot can choose robot configuration (confdata) itself which may give unpredictable results. If you don't use robot configuration, the robot program may behave differently depending on your starting position/configuration.

    My guess is that your starting configuration is different in the two cases. The motion behaviour is identical between VC and RC. The code running in the VC is identical to the RC for motion.

    /Henrik

    Henrik Berlin
    ABB