RobotStudio event

Library error for IRB6700 175-3.05


I'm working on a cell layout in Robotsstudio, with the goal to find a suitable robot. I'm looking at the new IRB 6700, but having problems with the 3.05 version(s). Downloading, unzipping and loading the library all works fine, and then I use the "build a controller from layout" function, which also seems to work. However, when I later want to jog my robot, the tool0 does not hold its's position when dragging it to the far ends of the working envelope. The error grows the further out I get (see enclosed picture). This error then affects all "far away" targets in paths, as it affects any created tools relatet to tool0, which is unstable. I haven't had the same problems with for example the 2.65 or the 2.80 versions which I've also tested. 

I have tried both the regular and the MH3, and mapping from library or mechanism (for the joints). No difference. Is something wrong with the inverse kinematics or library model for the 3.05, or am I doing something wrong? I so would like to test the robot, since it seems that it's the size I need. 

Regards Marie


  • Hi Marie,

    I am not able to reproduce your problem with RobotStudio 5.15.02 and RobotWare 5.15.02. Which versions of RobotStudio and RobotWare are you using? You could always try with RobotStudio 5.60 that just has been released.

    Here is the link to the download page:

    Kind regards,


    Henrik Berlin
  • I'm using 5.15.02 and the corresponding RW5.15.02. I've tried everything now exept standing on my head (re-installing, different ways to build the system etc) still no luck. Should downloaded libraries be put in ABBs own program folder or under the created Libraries folder under My Documents\Robotsstudio?

     I'll try downloading 5.60 next. 

    Regards! /Marie